我试图从Windows / apache服务器上的perl中的网页中使用Win32 :: OLE打开.xlsm文件。

在研究此问题时,遇到了以下可能的解决方案:

  1. 很少有人通过将其路径设置为绝对路径来解决该问题。 这对我没有任何帮助。

  2. 设置脚本的权限,使其具有访问服务器上文件的权限。 我不确定该怎么做。 但是,我正在通过Windows sspi验证我的用户,并且将有一个用户ID。 将在Win32 :: OLE上验证该用户ID的文件访问权限吗?

但是,我可以使用文件句柄打开文件。 我之前已经从网页上使用文件句柄对该服务器位置上的文件进行读/写。 win32 :: OLE权限是否与此不同?

错误是:

Microsoft Excel cannot access the file 'C:\test.xlsm'. There are several
possible reasons:

• The file name or path does not exist.
• The file is being used by another program.
• The workbook you are trying to save has the same name as a currently open
workbook.

Win32::OLE(0.1709) error 0x800a03ec
    in METHOD/PROPERTYGET "Open"

感谢任何输入。

===============>>#1 票数:5 已采纳

好的,经过多次尝试修改权限并以没有所需的所有必需特权的独立用户身份运行apache的尝试,终于摆脱了错误,方法是在

C:\\ Windows \\ SysWOW64 \\ config \\ systemprofile \\ Desktop

在msdn论坛http://social.msdn.microsoft.com/Forums/en-US/innovateonoffice/thread/b81a3c4e-62db-488b-af06-44421818ef91?prof=required中找到了希望的解决方案希望这将有助于在Windows中使用这些模块的人未来

  ask by Susithra translate from so

未解决问题?本站智能推荐:

2回复

在Cygwin下使用Perl Win32 :: OLE读取.xls文件时出现问题

我已经和这个人争斗了两天,我找不到解决方案而且我感到很沮丧。 使用Cygwin下面的代码时出现此错误 “Microsoft Office Excel”中的OLE异常:Excel无法访问“Empty.xls”。 该文档可以是只读的或加密的。 方法/属性中的Win32 :: OLE(0
1回复

如何将Excel文件保存在Win32 :: OLE的工作目录中

我正在尝试在perl中解析Excel文件。 从中提取所需的信息后,我关闭Excel文件。 最后,我尝试将一个具有不同名称的新Excel文件保存在同一目录中。 但是此Excel已存储在“我的文档”文件夹中。
1回复

如何通过Win32 :: OLE使用Excel Union函数?

我正在使用Win32 :: OLE从MSExcel 2010中的Excel数据表创建图表。数据不在连续的列中,并且我有一个具有每个数据范围的ds。 我正在尝试将所有这些数据范围合并为一个范围对象,例如: 效果很好,直到“ $ BS $ 1:$ BS $ 168”为止。 下一个数据在“
2回复

如何使用Win32 :: OLE设置Excel公式?

谁能告诉我,为什么...->{FormulaR1C1} = '=SUMME( "R[-3]C:R[-1]C" )'; 不起作用。 在显示结果的单元格中,我得到“ #Wert!”。 (也许是英语中的“值”)。 使用WENN(IF)公式,我得到了期望的结果。
1回复

我尝试使用Perl和Win32 :: Ole修改Excel

我为此而苦苦挣扎,并且有很多文章介绍了它应该如何工作,但是我没有成功: 我的系统是安装并激活Office 2016的Windows 7。 我想使用Excel文件作为模板进行修改并将其保存到新位置。 这是我的代码: 我收到“ Can't call method "Workshee
1回复

使用Win32 :: OLE模块操作Windows Excel的Perl命令列表[关闭]

有没有人使用基本的Win32 :: OLE模块在Windows上操作Excel的Perl命令列表? 特别是,我正在考虑以下操作: 打开并保存Excel文件 读取/更新值 阅读/更新公式 改变格式,边框 添加/编辑超链接 列出工作表 等等
2回复

将Visual Basic台站移植到Perl Win32 :: OLE台站

我阅读了所有标准的Win32 :: OLE文本,例如Jan Dubois的经典文章 ,当然还有官方软件包doc ,Microsoft的简洁文章等。 我错过的是将捕获的VBA Excel宏语句转换为Perl Win32 :: OLE的规则。 假设我有一个捕获的VBA宏: 假设我
1回复

试图了解为什么Perl Win32 OLE Excel Server引发异常

试图了解和诊断MS服务器2008上的Excel安装有什么问题。请参阅下面的MWE。 这在我的Win笔记本电脑上可以正常工作,但在服务器上却不那么出色。 通过干净的登录,它第一次可以正常运行,但是随后的运行会失败,并显示错误文本: 第一次运行将excel.exe留在任务管理器中。 我
2回复

如何使Win32 :: OLE在64位MS OFFICE安装上工作

我有两台PC,一台安装了MS Office 2013 32bit,另一台安装了MS Office 64bit。 我有Perl代码使用Win32::OLE Perl模块来操作XLS电子表格。 代码在32位PC上工作得非常好,但在64位PC上有问题。 经过一些研究后,我发现了这一点。 问
1回复

如何使用perl WIN32 :: OLE在单元格中编写公式

我尝试在Excel工作表中插入公式=IF(D2="";"";COUNTIF(D:D;D2)) 。 这是我正在尝试的代码: 我也尝试使用{Value}代替{Formula}失败! 我怎么了