我已经有两个星期了。 突然,这发生在我的项目上,而我却无法修复它。 它是一个基本的标签栏应用程序,我几乎还没有开始对其进行繁重的编码。 运行xcode 4.6.2(也尝试4.6和4.6.1)。

实际错误显示:“无法在所选目标上运行所选目标不支持为其构建所选软件的体系结构。请切换到支持该体系结构的目标,以运行所选软件。”

提前致谢。

===============>>#1 票数:5 已采纳

好了,这是我的新修复程序:由于某种原因,我更改了以下突出显示的行:

info.plist中

我已经将${EXECUTABLE_NAME}更改为其他名称。 改回来并不能立即解决问题:我必须先单击+添加新行,然后删除新行。

我的应用现在运行良好


旧修正:

好,是的,的确如此,还有其他类似问题。 他们帮助我找到了一个不同的(和陌生人)解决方案。

  1. 我在.xcodeproj文件上单击鼠标右键,然后选择“显示软件包内容”
  2. 然后我打开“ project.pbxproj”
  3. 我将所有文本从其复制到另一个文件,从其中删除了所有文本并保存
  4. 这“破坏”了我在XCode中意外打开的XCode项目。
  5. 我关闭了项目,然后将“ project.pbxproj”的原始内容粘贴回“ project.pbxproj”中
  6. 我保存了“ project.pbxproj”并关闭了它
  7. 再次打开XCode项目后,我可以在设备上运行它了!

对我来说,为什么这样做不起作用是没有道理的,因为我没有修改文件...但是确实如此,哇!

PS以防万一,请事先备份您的项目。

编辑 :我的井已经停止工作了,我无法使用上述方法来修复它...

  ask by Zachary Rosenberg translate from so

未解决问题?本站智能推荐: