我按照本教程创建了一个使用jsf的应用程序并将其部署在google app引擎上,即使我遵循了tuto的所有步骤

我遇到了这个错误:

    18 avr. 2013 01:01:10 com.google.apphosting.utils.config.AppEngineWebXmlReader readAppEngineWebXml
INFO: Successfully processed C:\Users\user\Desktop\eclispe_workspace\test_google\war\WEB-INF/appengine-web.xml
18 avr. 2013 01:01:10 com.google.apphosting.utils.config.AbstractConfigXmlReader readConfigXml
INFO: Successfully processed C:\Users\user\Desktop\eclispe_workspace\test_google\war\WEB-INF/web.xml
18 avr. 2013 01:01:10 com.google.appengine.tools.development.SystemPropertiesManager setSystemProperties
INFO: Overwriting system property key 'java.util.logging.config.file', value 'C:\Users\user\Downloads\Compressed\eclipse-jee-juno-SR2-win32\eclipse\plugins\com.google.appengine.eclipse.sdkbundle_1.7.7.1\appengine-java-sdk-1.7.7.1\config\sdk\logging.properties' with value 'WEB-INF/logging.properties' from 'C:\Users\user\Desktop\eclispe_workspace\test_google\war\WEB-INF\appengine-web.xml'
18 avr. 2013 01:01:10 com.google.apphosting.utils.jetty.JettyLogger info
INFO: Logging to JettyLogger(null) via com.google.apphosting.utils.jetty.JettyLogger
18 avr. 2013 01:01:11 com.google.apphosting.utils.jetty.JettyLogger info
INFO: jetty-6.1.x
18 avr. 2013 01:01:11 com.google.apphosting.utils.jetty.JettyLogger warn
ATTENTION: failed com.google.appengine.tools.development.DevAppEngineWebAppContext@14ab51b{/,C:\Users\user\Desktop\eclispe_workspace\test_google\war}: java.lang.UnsupportedClassVersionError: com/sun/faces/config/WebConfiguration : Unsupported major.minor version 51.0
18 avr. 2013 01:01:11 com.google.apphosting.utils.jetty.JettyLogger warn
ATTENTION: failed JettyContainerService$ApiProxyHandler@e8606c: java.lang.UnsupportedClassVersionError: com/sun/faces/config/WebConfiguration : Unsupported major.minor version 51.0
18 avr. 2013 01:01:11 com.google.apphosting.utils.jetty.JettyLogger warn
ATTENTION: Error starting handlers
java.lang.UnsupportedClassVersionError: com/sun/faces/config/WebConfiguration : Unsupported major.minor version 51.0
    at java.lang.ClassLoader.defineClass1(Native Method)
    at java.lang.ClassLoader.defineClassCond(ClassLoader.java:631)
    at java.lang.

你有什么主意吗

谢谢

===============>>#1 票数:1 已采纳

发生java.lang.UnsupportedClassVersionError的原因是,编译时JDK较高,而运行时JDK较低。 您无法使用JVM字节码target = 1.7部署Java代码,请尝试target = 1.6

  ask by simonTifo translate from so

未解决问题?本站智能推荐: