我已经在我的Gemfile中注释了我的rubygems版本是2.0+。 这是我运行git push heroku master时的输出:

Installing json (1.7.7)
       Installing rdoc (3.12.1)
       Installing thor (0.17.0)
       Installing railties (3.2.12)
       Installing coffee-rails (3.2.2)
       Installing commonjs (0.2.6)
       Installing formtastic (2.2.1)
       Installing formtastic-bootstrap (2.0.0)
       Installing hoe (3.5.0)
       Gem::InstallError: hoe requires RubyGems version >= 1.4. Try 'gem update --system' to update RubyGems itself.
       An error occurred while installing hoe (3.5.0), and Bundler cannot continue.
       Make sure that `gem install hoe -v '3.5.0'` succeeds before bundling.
 !
 !     Failed to install gems via Bundler.
 !
 !     Heroku push rejected, failed to compile Ruby/rails app

To git@heroku.com:limitless-river-5139.git
 ! [remote rejected] master -> master (pre-receive hook declined)
error: failed to push some refs to 'git@heroku.com:limitless-river-5139.git'

谢谢你的建议。

===============>>#1 票数:2

请执行以下操作:

gem update --system

然后

git push heroku master 

再次。

===============>>#2 票数:1 已采纳

我的.git中有几个项目。 他们中的一些人还有锄头宝石。 这导致了这个问题。

  ask by Joe Essey translate from so

未解决问题?本站智能推荐: