我在运行Windows XP的笔记本电脑上安装了Xming X Window Server,以连接到某些UNIX开发服务器。

当我直接连接到办公室的公司网络时,它工作正常。 但是,当我通过VPN远程连接到网络时,它不起作用。

当我在远程连接时开始Xming时,我的终端Windows都没有显示出来。

我认为这可能与DISPLAY环境变量在连接时没有正确设置到笔记本电脑的IP地址有关。

我注意到,当我在远程连接的情况下执行ipconfig时,我的笔记本电脑有两个IP地址,从公司网络分配的IP地址和我在我的“本地网络”上设置的本地IP地址调制解调器/路由器。

我是否需要在Xming中进行一些配置更改以支持其通过VPN使用?

===============>>#1 票数:5

感谢@Stephen和@Greg Castle的帮助,使用它我已经设法解决了我的问题。

为他人提供基本指南(从头开始):

在Windows PC上使用Xwindows通过VPN连接到UNIX服务器

你需要从什么开始:

该怎么办:

  1. 在Windows PC上安装上述两种方法

  2. 从Windows开始菜单中选择:程序 - > Xming - > Xming

  3. 在您下载它的位置运行Putty.exe程序

  4. 在PuTTY配置屏幕中,执行以下操作:

    • 将IP地址设置为UNIX服务器的IP地址

    • 选择SSH协议单选按钮

    • 单击配置屏幕左侧窗格中的SSH:Tunnels类别

    • 单击“启用X11转发”复选框

    • 单击“打开”按钮

    • 像往常一样登录到UNIX服务器

    • 检查路径中包含X windows实用程序的目录,例如Solaris上的/ usr / X / bin

    • 在putty窗口中运行X Windows命令,它们将在桌面上生成新窗口

===============>>#2 票数:5 已采纳

有可能是X身份验证,X服务器绑定到接口,或者您的DISPLAY变量。 我自己不使用Xming,但有一些普遍的现象需要检查。 您可以手动验证DISPLAY变量是否正确的一项测试是:

  1. 启动你的VPN。 运行ipconfig以确保您拥有您提到的两个IP地址(您的本地IP和您的VPN IP)。
  2. 开始Xming。 运行'netstat -n'以查看它如何绑定到接口。 您应该看到localIP:6000或VPNIP:6000。 它可能不是6000但可能会是这样的。 如果没有VPNIP:6000,它可能只绑定到您的localIP甚至127.0.0.1。 这可能不适用于VPN。 检查是否存在某些Xming设置以使其绑定到其他或所有接口。
  3. 如果您看到VPNIP:6000或类似内容,请记下它所说的内容和远程shell进入您的UNIX主机(希望像ssh一样,如果不是你必须获得文本终端)。
  4. 在UNIX终端上输入'echo $ DISPLAY'。 如果没有显示任何内容,请尝试'export DISPLAY = VPNIP:0.0',其中VPNIP是您的VPN IP地址,0.0是您在步骤3中看到的端口减去6000,最后是.0(即6000 = 0.0,6010 = 10.0)。
  5. 在UNIX主机上运行类似'xclock'或'xterm'的操作,看它是否运行。 错误消息应该是提供信息的。 它会告诉您它无法连接到主机(连接问题)或身份验证失败(您需要在主机和本地计算机上协调Xauth或在本地计算机上协调Xhost)。

如果你有一个本地保护的网络并且你正在通过VPN,那么打开Xhosts(对所有主机或类似的东西都是+)也不算太糟糕。 希望这会让你开始追踪问题。 另一个通常适用于VPN或简单ssh连接的选项是ssh隧道或通过ssh进行X11转发。 这通过将UNIX主机上的端口重定向到X服务器盒上的本地端口来模拟与本地盒上X服务器的连接。 您的显示器通常类似于本地6010端口的localhost:10.0。

X可以设置起来但是一旦你掌握了它,它通常会很好用。

===============>>#3 票数:2

我让Xming和PuTTY与Cisco VPN一起工作,取代了Connection > SSH > X11 > X display location localhost:0.0 ,使用VPNIP:0.0的PuTTY配置。 通过左键单击VPN client锁定图标,然后选择Statistics...可以在VPN statistics client address information看到VPNIP

我没有使用远程主机上的DISPLAY环境变量。 但是,和其他人一样,我修改了远程主机上的sshd_config,添加了以下行:

X11Forwarding yes
X11DisplayOffset 10
X11UseLocalhost yes
AddressFamily inet

===============>>#4 票数:1

我在Windows 10机器上遇到了与Xming和Putty相同的问题,并在此处找到了解决方案。 我已经克服了仅在PuTTY中向会话添加隧道的问题。 但首先你需要检查;

  • / etc / ssh下的sshd_config (在rhel7中)。
  • 在左侧导航窗格Connections > SSH > X11 启用X11转发
  • / etc / sysconfig /下的iptables (在rhel7中)。 如果端口被阻止并且您有权限,请打开6000的端口。我在第一个拒绝线之前添加了下面一行,以打开从6000到6003的端口。在您的情况下可能更具体。

    -A INPUT -m state --state NEW -m tcp -p tcp -m multiport --dports 5901:5903,6000:6003 -j ACCEPT

然后;

  • 转到PuTTY中的Connections > SSH > Tunnels ,添加一个Source Port=6000Destination=127.0.0.1:6000的隧道,然后选中Remote单选按钮。 然后单击“ Add按钮。
  • 建立SSH连接后,使用以下命令手动设置DISPLAY变量:
    export DISPLAY=127.0.0.1:0.0

更多信息;
如果将DISPLAY变量设置为127.0.0.1:1.0 ,它将通过6001端口进行通信。 在这种情况下,您需要为端口号6001添加另一个隧道。

===============>>#5 票数:1

我只有Xming的问题。 当我可以让它工作时它非常慢(这是通过VPN)。 IMO X不是设计用于缓慢连接,而是过于繁琐。 通过慢速连接,我的意思是少于LAN连接。

我的解决方案是使用x11vnc。 它允许您通过VNC访问现有的X11会话。 我只是通过VPN进入我的盒子并启动:

$ x11vnc -display :0

这样我可以访问我在白天打开的所有内容。 然后,当我不这样做时,我只是在终端中退出( Ctrl - C )以关闭x11vnc。

===============>>#6 票数:0

没有确切的问题,但我认为您需要查看xhost并确保允许vpn远程数据发送到x服务器。

此链接可能有所帮助: http//www.straightrunning.com/XmingNotes/trouble.php

===============>>#7 票数:0

你可能有更好的运气通过SSH进行X11转发而不是直接摆弄你的DISPLAY变量。 X11使用SSH进行转发是安全的,并使用现有的SSH连接进行隧道连接,因此通过VPN进行操作应该没有问题。

幸运的是,这对于Xming来说相当简单。 如果你从Xming内部打开你的连接(例如plink选项),我相信它默认设置X11转发。 如果使用其他SSH客户端(例如PuTTY)进行连接,则只需启用X11转发(例如'ssh -X user @ host')。 在PuTTY中,选项位于Connection - > SSH - > X11 - >单击'Enable X11 Forwarding'。

确保Xming在笔记本电脑的后台运行并进行标准X测试'xclock'。 如果您收到“X连接到localhost:19.0已损坏(显式终止或服务器关闭)”等消息。 然后Xming很可能没有跑。

另外,请确保您没有在任何启动脚本中明确设置DISPLAY变量; SSH将为X11隧道设置别名(类似于localhost:10或在localhost:19上面的示例中),并自动将DISPLAY设置为该值。 覆盖DISPLAY显然意味着你将不再指向正确的X11隧道。 另一方面,没有SSH X11转发集的其他终端可以使用相同的DISPLAY值并利用隧道。

我倾向于选择PuTTY选项,但是我的几个同事在Xming中使用了plink。

===============>>#8 票数:0

您必须将Linux计算机的DNS名称和IP地址添加到C:\\ Program Files \\ xming \\ X0.hosts文件中。 文件应包含:

LinuxBox.mydomain.com
LinuxBox
192.168.1.25

这是正确答案: https//www.slackwiki.com/X_Windows_Remote_X_to_Windows_with_Xming

===============>>#9 票数:0

putty + XMing - 我必须手动设置DISPLAY环境变量才能运行(同时在putty中检查“启用X11转发” - 连接/ SSH / X11)

export DISPLAY = 0:10.0

(它被设置为“localhost:10.0”,这不起作用)

  ask by David translate from so

未解决问题?本站智能推荐: