我和这篇帖子基本上有同样的问题: 当运行pod install我得到`master` repo需要CocoaPods 0.32.1,尝试更新但仍然在0.31但是答案对我没有帮助(我不允许发表评论哈哈!)

我尝试运行'pod install'或'pod setup',我收到一条错误信息:

[!] The `master` repo requires CocoaPods 0.32.1 - 
Update CocoaPods, or checkout the appropriate tag in the repo.
/Library/Ruby/Gems/2.0.0/gems/claide-0.5.0/lib/claide/command.rb:281:in `rescue in run': undefined method `verbose?' for nil:NilClass (NoMethodError)
    from /Library/Ruby/Gems/2.0.0/gems/claide-0.5.0/lib/claide/command.rb:274:in `run'
    from /Library/Ruby/Gems/2.0.0/gems/cocoapods-0.31.1/lib/cocoapods/command.rb:51:in `run'
    from /Library/Ruby/Gems/2.0.0/gems/cocoapods-0.31.1/bin/pod:33:in `<top (required)>'
    from /usr/bin/pod:23:in `load'
    from /usr/bin/pod:23:in `<main>'

然后我运行'sudo gem install cocoapods',我得到:

CHANGELOG:

## 0.32.1

##### Bug Fixes

* Fixed the Podfile `default_subspec` attribute in nested subspecs.  
  [Fabio Pelosin][irrationalfab]
  [#2050](https://github.com/CocoaPods/CocoaPods/issues/2050)


Successfully installed cocoapods-0.32.1
Parsing documentation for cocoapods-0.32.1
Done installing documentation for cocoapods after 1 seconds
1 gem installed

即使在此之后,我运行'pod --version',我仍然得到0.31.1。 我需要采取另一个步骤来成功更新到0.32.1吗?

===============>>#1 票数:31 已采纳

更新:在sudo gem uninstall cocoapods之后需要重新启动TERMINAL

然后sudo gem install cocoapods成功更新到最新版本。

===============>>#2 票数:9

运行pod --versionsudo pod --version - 我想有多个版本已经安装了sudo和没有sudo。 要么更新两者,要么使用[sudo] gem uninstall cocoapods删除不需要的第二个

===============>>#3 票数:4

尝试首先卸载gem:

sudo gem uninstall cocoapods

然后再次安装:

sudo gem install cocoapods

然后pod --version应该显示最新的。

===============>>#4 票数:1

对我来说,问题是由安装了两个版本的cocoapods引起的。

我首先通过运行sudo gem uninstall cocoapods

然后运行pod --version命令再次检查cocoapods的存在。

发生了奇怪的事! 宝石就在那里。 所以我第二次卸载了cocoapods。

我的结论是确保您完全删除所有cocoapods,然后重新安装它。 这个对我有用。

===============>>#5 票数:1

我正在使用捆绑包,所以bundle update cocoapods适合我。

===============>>#6 票数:0

最终对我有用的是......

- sudo gem uninstall cocoapods
- Restart the Terminal ( on your Mac)
- sudo gem install cocoapods --source http://rubygems.org

还有,更好的复制粘贴,容易用Cocoapods打错字:-)

  ask by EAB translate from so

未解决问题?本站智能推荐:

2回复

CocoaPods更新。 终端显示以前的版本[重复]

这个问题已经在这里有了答案: podfile在安装时给出错误 3个答案 我试图用sudo gem install cocoapods命令更新cocoapods gem。 在安装几分钟后,我看到Successfully installed cocoapods-0.2
2回复

CocoaPods安装失败(无法解析依赖项)

我在MacOS X 10.3上安装CocoaPods时遇到问题。 第一次尝试失败并带有DependencyError用于小睡。 我安装午睡并再次尝试相同的结果。 卸载并重新安装没有帮助。
7回复

无法从rubygems.org安装'cocoapods'宝石(错误的响应后端读取错误)

当我在OSX Mavericks上运行'gem install cocoapods'时出现错误。 请注意,我可以直接下载cocoapods-0.27.1.gemspec.rz。 我正在运行最新版本的XCode(5.0.1)及其最新版本的CLI工具。 RVM还配置为运行最新的Ruby版
1回复

吊舱安装失败,并显示以下错误:错误:1006706B:椭圆曲线例程

我有两台Mac,都是最新的OS X和Xcode。 一方面,我可以安装cocoapods和项目的podfile中指定的pod。 另一个失败: pod install --verbose准备 更新本地规格存储库 建立规范的回购浅克隆master从https://gith
1回复

Cocoapods安装构建错误

我试图在我的Mac上安装cocoapods,但出现以下错误: 我到处搜索,找不到任何答案。 [更新]看着生成的Makefile,CC变量为空 真的很奇怪!
1回复

安装cocoapods后无法进行吊舱设置

我已经安装了可可豆荚,何时安装 吊舱设置 我得到以下错误 我需要安装active_support吗?
2回复

更新后无法使用cocoapods

我在mac OSX 10.9.5上更新了Ruby,Gems和Cocoapods,更新后我无法执行命令 我从终端得到以下错误 我创建了一个包含以下内容的Podfile Cocoapods在更新前完美运作。 任何帮助是极大的赞赏。
4回复

Pod设置找不到cocoapods

使用sudo gem install cocoapods安装cocoapods后,尝试运行“pod setup”会返回此错误: “pod setup”的输出: 当我检查GEM_PATH中列出的目录时,它包括: 所以文件在那里,虽然它的核心是root,因为我使用了sudo
1回复

将cocoapods更新到最新版本没有任何作用

我目前正在使用cocoapods 0.26.2( pod --version输出)。 我想将其更新为0.29.0。 我运行了sudo gem update ,它似乎对cocoapods gem没有任何作用。 因此,在cocoapods.org上提出了以下建议: 那似乎确实安装了
5回复

当运行pod install我得到`master` repo需要CocoaPods 0.32.1,尝试更新但仍然在0.31

我试图在xcode项目中安装可可豆荚但是在做的时候: 我收到以下错误: 所以我更新了cocoapods 但它告诉我没有更新: 运行pod --version 但我得到: 会是什么呢? 为什么不更新到最新版本(.32.1)? Xcode:5.