因此,我安装了Rails应用程序,并在我的hostmonster帐户上正常工作。 然后,我在我的开发环境中更新了一些东西/将它们推送到github /将它们拉回到我的生产环境中。 现在,它给我的错误是Could not find pg-0.17.1 in any of the sources (Bundler::GemNotFound)

这是我在开发人员中安装的一个新gem,因为我正尝试迁移到postgresql进行开发和发布。...目前,我在开发人员中使用postgresql,在生产环境中使用mysql2。 我知道这不是最佳选择,但我正在努力。

我尝试运行bundle installbundle install pg gem,但由于错误而失败

Gem::Exception: Cannot load gem at [/usr/lib64/ruby/gems/1.9.3/cache/rake-10.2.2.gem] in /home4/muscorei/workspace/vollapp An error occurred while installing rake (10.2.2), and Bundler cannot continue. Make sure that gem install rake -v '10.2.2' succeeds before bundling.

我尝试安装rake,但工作正常...再试一次。 我在这里找到了一个似乎可以解决其他问题的问题,但它需要运行gem update --system ,而对于hostmonster则无法做到。 有任何想法吗?

因此,这是另一个“相关”问题。 当我输入gem list --local时,我看到Rails的版本为4.1.0 ....但是,当我执行rails -v时,它将显示系统范围的3.2.13版本。 在我的开发环境中,我从来没有任何这些烦人的问题。

  ask by Bill Garrison translate from so

本文未有回复,本站智能推荐: