我正在尝试为PHP安装mongo模块,当我尝试时,几乎在网上找到的所有安装指南都使用pecl: sudo /usr/local/pear/bin/pecl install mongo

我收到此错误:

No releases available for package "pecl.php.net/mongo"
install failed

我是否将pecl配置错误或已终止?

===============>>#1 票数:5

您能粘贴的输出

pecl config-show
pecl version

我真的无法想象这怎么可能? 也许运行的是非常老的梨子(自从更改软件包格式之前(甚至是2008年或更早)。您可以实际安装任何pecl扩展名吗?

在任何情况下,您都可以通过首先下载扩展程序,然后使用本地归档文件进行安装来安装扩展程序:

wget http://pecl.php.net/get/mongo
pecl install mongo-*.tgz

  ask by Chakradar Raju translate from so

未解决问题?本站智能推荐:

2回复

在amazon linux上安装PHP的mongo驱动程序时出错

我试图在Amazon Linux上安装PHP的mongodb驱动程序。 在运行sudo pecl install mongo ,我收到错误消息: PEAR版本:1.9.5 PHP版本:5.3.29 我安装了gcc,这帮助我进一步推进安装直到出现此错误。 我能找到的最佳指南是
2回复

php5-mongo和pecl mongo-stable

如果我已经使用PECL成功安装了mongoDB,是否需要获得debian软件包“ php5-mongo”? 有什么不同? (并且该问题应该迁移吗?)
1回复

Mac OSX Mavericks升级后,PHP和Mongo崩溃了

在OSX 10.9.3升级之后,许多事情都无法正常工作。 Apache,Mongo和PHP现在都是独立工作,但php的mongo扩展不是。 我希望stackoverflow社区可以提供帮助。 这是基本问题: Pecl和PHP对是否存在mongo扩展存在分歧。 mongo.so确实
2回复

PHP,mongo.so未能写

任何帮助都会很棒。 我已经坚持了几个小时。 我正在尝试安装Mongo以在Mac上使用PHP。 我安装了Pear / pecl并正在工作。 当我调用sudo pecl install mongo ,一切看起来都在成功编译/构建,但最后我收到了这条消息。 构建过程成功完成安装'/u
1回复

Mongo连接失败

我正在我的本地mac上运行mongodb,它与MAMP结合运行良好。 然而它不起作用,当我在终端中调用它时,我现在得到这个: 有任何想法吗? 谢谢!
1回复

MongoDB php7驱动程序安装

我正在Ubuntu 16服务器上工作,但似乎无法获得适用于php 7的mongodb驱动程序。 我已在Windows机器上的xampp上成功安装了它,但是Ubuntu和php7似乎有很大的不同。 我确实尝试通过pecl install mongodb安装它,并使用composer放入了依
1回复

在Mac OS X Yosemite上安装mongoDB PHP驱动程序

我在OS X Yosemite中安装mongo PHP驱动程序时遇到问题。 我在Mavericks中安装和配置了它。 这是我在终端中得到的: 我已经安装和更新了Xcode,以及命令行工具。 佩克(Pecl)是否因优胜美地(Yosemite)而改变,还是其他人遇到了同样的问题?
2回复

如何在Windows 8和WAMP服务器上安装mongodb php驱动程序?

我正在尝试在php中安装mongodb驱动程序。 我将wamp服务器与PHP 5.5.12一起使用。 我已经尝试了很多,但是不知道我在做什么错。 这是我所做的: 步骤1:我从以下链接下载了mongodb驱动程序包: http : //pecl.php.net/package/mong
1回复

如何修复无效的对象ID Mongo异常

我有这个代码 在我的开发服务器上工作正常,但在本地计算机上崩溃。 在开发人员返回上运行pecl list 以及本地回报: 我机器上的崩溃消息是 我曾尝试将本地版本的mongo降级,但由于pecl的文档不完善,我无法弄清楚。 例如我尝试了这个: 但我
3回复

如何在Netbeans中启用PECL Mongo类的自动完成

是否有机会在netbeans中启用/启用Mongo PHP PECL类的自动完成功能?