我想知道我是否可以将buildozer用于非奇异的python脚本。 是否可以使用除kivy脚本之外的普通python脚本来构建apk文件?

===============>>#1 票数:1

我会说这可能是不可能的。 但是,您应该在kivy支持小组中询问。 您需要加入才能发布。 那里的有些人似乎真的很了解自己的知识,根据我的经验,我不必等待太久就可以找到答案。

编辑:

如果查看项目的buildozer.spec文件,默认情况下将包含以下行:

# (list) Application requirements
requirements = kivy

尽管这似乎使kivy成为了buildozer的所有项目的要求,但是您可以尝试注释掉这些要求或其他内容,并查看当您尝试在没有kivy的情况下编译代码时会发生什么。

或因为这样做有点倒退,因为您必须已经创建了buildozer.spec文件。 也许您可以尝试在没有基调的项目上使用buildozer,然后看看会发生什么。

  ask by bukman translate from so

未解决问题?本站智能推荐:

1回复

buildozer-使用其他python版本(非默认2.7.2)

我正在尝试使用比Buildozer默认使用的版本(2.7.2)更新的版本来编译Andriod apk文件。 原因是,我有一个需要2.7.7或更高版本的库,并且我对使用特定库创建自己的完整Python构建信心不足。 该应用程序可以在运行2.7.12的Linux PC上完美运行。 将P
1回复

buildozer-用于Python代码的INSTALL_FAILED_CPU_ABI_INCOMPATIBLE

我正在使用Buildozer ,它应该为我创建一个.apk,而不会带来太多麻烦。 我使用该库编写了python脚本。 换句话说,我编写的python代码与Android完全无关,但我想在Android上将其用作后端/库。 我编写的python代码可以在笔记本电脑上正常运行。 Bu
1回复

在Python中生成非奇异稀疏矩阵

当scipy.sparse.rand生成稀疏矩阵时,它可以是scipy.sparse.rand 。 实际上,以下代码"RuntimeError: superlu failure (singular matrix?) at line 100 in file scipy/sparse/linalg
1回复

使用buildozer在python上制作apk

我正在尝试用buildozer做apk,但我总是会收到此错误: 我读到有关此问题的信息,并发现建议我应该安装32位库的建议,但它对我没有任何帮助,所以我不知道该怎么办:(
1回复

Buildozer更新python代码

这听起来可能很愚蠢,但是我无法弄清楚如何使用buildozer更新main.py代码。 我曾经创建一个文件main.py并运行buildozer init 。 之后,我执行了一些android命令,例如buildozer android run 。 现在,我想更改main.py的代码。
1回复

GSVD用于python广义奇异值分解

MATLAB具有执行通用SVD的gsvd函数。 自2013年以来,我认为在github页面上已经有很多关于将其放入scipy的讨论,并且有些页面包含我可以使用的代码,例如在这里 ,对于像我这样的新手来说(使其运行)超级复杂。 我还找到了带有实现的 LJWilliams github页面。
1回复

Buildozer尝试编译一个简单的“ hello world”奇异项目,但抛出错误

在终端上,我输入以下内容: 回溯错误: 我收到此错误: 我使用的是Imac“ El Capitan” Python 2.7 / Kivy 1.9 / Cython 21.1。
1回复

Python,Kivy,Buildozer:SymPy使APK崩溃

如标题所示,我制作了一个.apk在我的Android手机上运行。 它可以在PC上完美运行。 一旦我取出所有SymPy命令,它也会在Android上运行。 我已经在buildozer.spec文件中提到了“ sympy”,它没有给出任何错误。 但是,一旦我的Android屏幕上的加载结束,
1回复

buildozer失败,使用纯python库(品脱)

我正在尝试创建一个kivy应用程序,并且我想包含pint库,因此我在我的buildozer.spec文件中添加了pint : 但是,运行时 我收到一个错误(请参阅下面的日志)。 如果我从需求中删除pint ,一切都会很好,但是我不明白为什么这会导致错误,因为pint是一个没有依
1回复

使用Python for Android(Buildozer)签署Android应用

我正在使用Buildozer将Python脚本编译为Android可执行文件(.apk)。 但是我有一个问题:我无法在Android上运行它们(我已将其安装在虚拟机中)。 我发现我需要对应用程序进行签名才能运行它。 那么,如何签署我的申请? 我正在使用GNU / Linux。