我正在尝试安装指南针和Susy。 在Win8上安装ruby并执行后

gem update --system

我尝试使用安装罗盘

宝石安装罗盘

但是我得到了以下错误:

错误:执行gem时...(Errorno:EMSGSIZE)在数据报套接字上发送的消息大于内部消息缓冲区或某些其他网络限制,或者用于接收数据报的缓冲区小于数据报本身。

我的命令提示符版本是6.2.9000(但我认为它没有任何区别)但是,完全相同的步骤在其他机器上工作。 有什么想法吗?

参考: http//compass-style.org/install/

===============>>#1 票数:0

你可以检查ruby的安装位置。 如果它在C:\\ruby ,则可能是由于对文件夹的访问。 您可以在Administrator模式下运行终端,以便它具有所需的访问权限。

Super key + x然后选择Command prompt(Admin)

输入以下内容:

gem update --system

gem install compass

  ask by helloworld translate from so

未解决问题?本站智能推荐:

1回复

执行gem时出错(Errno :: EACCES)

在尝试更新Ruby gems 2.1.0之后,通过运行命令“ gem update --system”,我收到一条错误消息: 有人可以帮我解决此问题吗? 谢谢高级
2回复

执行gem时出错...权限被拒绝

我正在尝试从我的Heroku app文件夹安装水龙头。 当我输入“gem install tap”时,我收到以下错误: 错误:执行gem时...(Errno :: EACCES)权限被拒绝 - /Users/jacob/.rvm/gems/ruby-1.9.3-p194/gems/t
1回复

安装gem时出错

我在终端中输入“ gem install middleman”,并收到以下错误消息:
1回复

从gem运行可执行文件时出错,因为另一个gem不包含在包中

我正在创建一个将ruby-git( https://github.com/schacon/ruby-git )作为依赖项的gem(请参阅https://github.com/hamchapman/rewinder )。 我的gem的一部分具有可执行文件https://github.com/
2回复

Ruby Gem安装失败-执行gem时出错-未初始化的常量Syck :: Syck

我正在使用gem 1.3.7,Ruby 1.9.2和Rails 3.0.7。 突然,当我尝试更新任何gem时,出现以下错误消息: 我该如何解决? 这以前工作过...
1回复

安装rails gem时出错

所以我在VPS上安装了ruby 2.2.0,我正在尝试安装rails。 唯一的问题是,当我做一个gem安装rails它失败了。 我用回溯尝试了它,以下是我得到的: 我还运行了gem install --backtrace -p rails并获得了以下内容 它似乎在我的其他VP
2回复

安装pg gem时出错

我在尝试安装'pg'时遇到以下错误有何想法? 我对rails很新,所以我不知道如何解决这个问题。
2回复

安装gem pg时出错

我正在尝试运行“bundle install”,我在我的Gemfile中唯一的数据库gem是pg,所以我收到以下错误。 我在网上找不到任何东西,请有人帮忙! 谢谢!!
2回复

安装ruby gem时出错

我正在尝试安装红宝石宝石。 我收到了这个错误。 我搜索过这个网站,却一无所获。 我也用google搜索过,发现只更新ruby gems可以解决问题,但事实并非如此。 我有ruby gems 1.2.0和ruby 1.8.6(2007-09-24 patchlevel 111)[
3回复

从gem安装RMagick时出错

尝试安装RMagick gem失败,并显示有关找不到ImageMagick库的错误,即使我确定它们已安装。 gem install rmagick的相关输出为: 并查看mkmf.log显示: 这是在Solaris 10 x86上,具有ImageMagick版本6.4.3和R