我启动地图项目,并按照https://developers.google.com/maps/documentation/android/start#getting_the_google_maps_android_api_v2的说明进行操作

当我添加此代码片段时,出现错误

<?xml version="1.0" encoding="utf-8"?>
<fragment xmlns:android="http://schemas.android.com/apk/res/android"
      android:id="@+id/map"
      android:layout_width="match_parent"
      android:layout_height="match_parent"
      android:name="com.google.android.gms.maps.MapFragment"/>

错误

[2014-04-21 06:32:21 - appcompat_v7_3] WARNING: unable to write jarlist cache file C:\Users\Umer Mir\workspace\appcompat_v7_3\bin\jarlist.cache
[2014-04-21 07:14:23 - google-play-services_lib] Unable to resolve target 'android-9'
[2014-04-21 07:14:26 - google-play-services_lib] Unable to resolve target 'android-9'
[2014-04-21 07:45:30 - Mapsproject] Error in an XML file: aborting build.
[2014-04-21 07:45:41 - Mapsproject] Error in an XML file: aborting build.

===============>>#1 票数:1 已采纳

将您的Android目标android-8更改为其他任何目标。

Your Project--->Right Click-->Properites-->Android-->Select Google API 15(whatever you have)-->

要么

将此添加到Android清单文件中。

<uses-sdk
        android:minSdkVersion="8"
        android:targetSdkVersion="15" />

您可以添加目标SDK,但必须为Google API

  ask by Meerz translate from so

未解决问题?本站智能推荐: