繁体   English   中英

npm angular package的问题

Issues with npm angular package

提示:本站收集StackOverFlow近2千万问答,支持中英文搜索,鼠标放在语句上弹窗显示对应的参考中文或英文, 本站还提供   中文繁体   英文版本   中英对照 版本,有任何建议请联系yoyou2525@163.com。

我试图弄清楚到底是什么问题。

所以我有一段代码可以与

<script src="//ajax.googleapis.com/ajax/libs/angularjs/1.3.5/angular.min.js"></script>

但是当我使用通过NPM在本地安装的角度时,它就坏了。

现在我正在使用的NPM本地版本是1.3.5,并在package.json中将其列为

  "dependencies": {
    "angular": "1.3.5"
  }

当我将package.json更改为

  "dependencies": {
    "angular": "^1.3.5"
  }

所以它拉了最新版本我得到这个警告

npm WARN deprecated angular@1.3.36: bad package, use v1.3.5 instead

所以我回到了1.3.5版本...。但是它仍然无法与我的angular本地副本一起使用。

我究竟做错了什么?

作为参考,这是我在做什么的一个例子http://jsbin.com/sibejocopi/1/

如您所见,它更新了最新时间,但是使用我的angular的npm副本并没有改变。

1 个回复

我不确定“使用本地的angular副本工作”是什么意思。 您正在构建网站还是单页应用程序? 如果是这样,您将希望使用上面引用的“ //ajax.googleapis.com / ...”引用,因为您的用户更有可能将其保存在浏览器缓存中。

还是您要进行设置以便可以离线使用网站?

无论哪种情况,我都需要更多信息才能回答这个问题。 您如何服务文件-表达? Nginx? 您的服务器配置是什么? 当它不起作用时,如何指定本地angular.min.js的路径? 您是否看过通常被认为更适合于服务Web资产的其他程序包管理器(例如bower )?

1 npm连结 问题

Windows 7,64位 Npm 3.10.10 节点6.9.4 你好 目前,我们正在使用自定义npm软件包(已发布在注册表中,并已安装在Angular应用程序中),这会带来一些麻烦。 参见下面我们测试过的不同方案: 生成软件包,将其发布在我们的注册表中, ...

5 npm安装 不工作

我正在尝试按照教程并在我的项目中安装角度包。 我的系统中已经安装了npm(4.0.5)和节点(6.9.2) 我在我的项目文件夹中运行: 但是我的项目目录中没有安装node_modules文件夹。 我已经尝试过这个命令但仍然没有工作: 我运行npm install a ...

7 Angular8 node js和npm安装问题

我正在学习角 js。 为此,我安装了 nodejs 和 git。 我在 CMD 上运行了以下命令: 一段时间后出现以下错误 你能解释一下那个错误是什么以及我如何解决这个问题。 我正在使用窗口 10。 ...

8 Angular5 Node js和npm安装问题

我安装了最新版本的Node和NPM,并使用它安装了Angular / cli,但是使用以下错误正在向我射击: angular / cli和npm版本与node的当前版本不兼容 。 我怀疑我可能会(不在)正确的目录中进行安装。 但是到现在,我还能做什么? 谢谢。 请检查: 屏幕截图 ...

9 Angular4 NPM启动问题

我试图运行命令npm start,然后再安装nodejs,npm install。 图像文件中已包含以下问题。 请给我很大的帮助。 ...

2017-10-11 11:54:23 2 29   angular
10 Angular 2/4 npm安装问题

当我尝试通过npm安装angular时,出现以下错误消息: npm install -g @ angular / cli 当前设置: 节点-v v6.11.1 npm -v 5.3.0 ...

暂无
暂无

声明:本站的技术帖子网页,遵循CC BY-SA 4.0协议,如果您需要转载,请注明本站网址或者原文地址。任何问题请咨询:yoyou2525@163.com.

 
粤ICP备18138465号  © 2020-2022 STACKOOM.COM