我最近刚刚开始在项目中使用gulp.js,并且我一直在尝试学习和使用终端更多。

当我从Mac终端默认控制台运行npm命令时,一切正常,但是当我在PhpStorm中运行相同的命令时,找不到该命令。

我已经按照PhpStorm的指南安装和集成NodeJS插件等,但是即使它在我的usr/local/bin并且已全局安装,我似乎也无法通过它获得任何命令。

当我可以使用npm命令等通过SSH进行npm有人能提出任何建议吗?

  ask by user2391468 translate from so

本文未有回复,本站智能推荐:

1回复

从PhpStorm运行npm启动时出错

我可以从Windows的命令提示符运行npm start而不会出现问题,但是使用PhpStorm终端时却出现错误 。 他们实际上是不同的事物还是其他某种问题。 字符集?
2回复

在尝试安装新的NPM软件包时,请在PhpStorm/WebStorm中指定“npm或yarnpackage”

尝试添加新包我收到以下错误: 翻看设置一切看起来都很好: 有什么建议去哪看?
1回复

PhpStorm/WebStormnode_modules和package.json

一些相关的问题: 首先,我使用的是PhpStorm 9.0.2,并希望将node_modules软件包目录从项目的根目录移至子目录。 但是,当我尝试执行此操作时,我安装的所有软件包都不再显示在“ Node.js和NPM”设置页面中。 我似乎找不到在哪里设置路径,这甚至是可以做的事情吗?
3回复

env:node:编译less时,phpstorm中没有这样的文件或目录

我正在尝试使用phpstorm将main.less文件编译为main.css文件。 但是,我收到此错误, .less文件无法编译。 我正在使用mac而不确定为什么会这样。 它之前工作正常,但我重新启动了我的电脑,现在我收到了这个错误。 有谁知道为什么会发生这种情况以及如何解决?
1回复

npm创建了大量文件,我在做什么错?

我阅读PhpStorm手册这一部分的方式,以添加开发工具,我可以这样做: 如果工具是文档或测试框架,对于那些将要重新使用您的应用程序的人来说都是不需要的,那么将来将其从下载中排除是很有用的。 这是通过将该工具标记为开发依赖关系来完成的,这实际上意味着将该工具添加到package.json
1回复

PhpStorm/WebStorm终端显示旧的NPM版本

我在运行PhpStorm 2018.3 Windows 10 x64上。 我已经将NodeJS更新到10.14.1,其中包括NPM 6.4.1。 Windows命令行工具显示正确的版本 PhpStorm设置显示正确的版本 我遇到的问题是,尽管PhpStorm终端显示了正确的节点
1回复

npm安装后,phpStorm太慢

不好意思说英语是我的第二语言。 我创建了一个新的Laravel项目,然后composer install和npm install在ITERM。 然后,我想通过PhpStorm打开项目,但是IDE太慢了,无法打开它。 索引文件的时间超过1小时! 我试图将内存限制从768mb增加到20
1回复

npm命令在PhpStorm内的gitbash终端中不起作用

我已在PhpStorm中将Shell path设置为sh.exe ,但无法在控制台中运行npm命令。 它说: bash: npm: command not found命令,但是我可以在PhpStorm外部打开的普通git bash控制台中运行该命令。