指定特定版本时,无法安装ruby gem'sys-proctable':

$ /opt/chef/embedded/bin/gem install sys-proctable -v 0.9.6 --verbose --explain
HEAD https://api.rubygems.org/api/v1/dependencies
200 OK
GET https://api.rubygems.org/api/v1/dependencies?gems=sys-proctable
200 OK
ERROR:  Could not find a valid gem 'sys-proctable' (= 0.9.6) in any repository
GET https://api.rubygems.org/latest_specs.4.8.gz
302 Moved Temporarily
GET https://s3.amazonaws.com/production.s3.rubygems.org/latest_specs.4.8.gz
200 OK
ERROR:  Possible alternatives: sys-proctable

但是,如果我未明确指定版本,则可以使用我之前尝试使用的完全相同的版本来工作

$ /opt/chef/embedded/bin/gem install sys-proctable --verbose --explain
HEAD https://api.rubygems.org/api/v1/dependencies
200 OK
GET https://api.rubygems.org/api/v1/dependencies?gems=sys-proctable
200 OK
Gems to install:
  sys-proctable-0.9.6

使用冒号语法( sys-proctable:0.9.6 )指定版本没有任何区别,或者使用--platform universal-linux指定平台。

当我直接下载https://api.rubygems.org/api/v1/dependencies?gems=sys-proctable时 ,实际上存在适用于Linux的0.9.6版本。

有什么事吗 gem的版本是2.4.4。

#1楼 票数:1

这对我有用:

gem install sys-proctable '0.9.6'

#2楼 票数:0 已采纳

Chef捆绑的rubygems版本存在问题: https : //github.com/chef/chef/issues/3033

  ask by John Dough translate from so

未解决问题?本站智能推荐:

3回复

Rails:为 gem 指定版本的利弊?

我是 Rails 的新手——指定确切的(当前)gem 版本有什么优点和缺点? 以下是我的引擎中的宝石: 添加版本是否确保 gem 的未来版本不会破坏应用程序? 但这不是意味着您不会得到任何错误修复吗?
2回复

从Github指定gem的分叉版本时出现'找不到gem'错误

我正在尝试使用ebay api gem的分叉版本( https://github.com/codyfauser/ebay/ ) 但是,当我运行bundle install时,我收到错误。 原始宝石工作正常。 ( https://github.com/codyfauser/eba
1回复

在使用rbenv时如何指定要使用的gem。 多个版本安装了相同的gem

我一直在使用Sass 3.2.13。 我想尝试3.3版本中的sourcemap生成,所以我安装了3.3版本。 '宝石清单| grep sass的回报 我想从命令行调用sass 3.3。 我不是在ruby项目中使用sass。 我发现该格式应该可以工作: 因此,
1回复

当未指定版本时,为什么捆绑程序需要一个非常旧的gem版本?

我有一个看起来像这样的Gemfile: 我有一个基本的宝石,需要跨项目的一堆共同的宝石。 但是,当我运行bundle install ,会看到如下错误: google-api-client不需要机架1.2,因为像版本0.1一样,而且my_baseimage需要0.7.1。
1回复

如何指定Gemfile,使其不会安装特定版本的gem

我是ruby的新手,我正在尝试指定要rack的特定版本号。 我想要安装1.4.5并移除1.5.2 ,并且我执行gem uninstall rack --version 1.5.2 ,并在文件Gemfile.lock rack的版本号指定为1.4.5 。 但是,今天早上起床后,我发现重新安
2回复

无法在任何存储库中找到有效的gem“rails”(> = 0)

有没有人花更多的时间与轨道摔跤比实际编码? 对于一般的rails和编程来说是非常新的,所以如果这是一个非常简单的问题我会道歉。 我不太了解这里有什么问题。 我升级到ruby 2.2.2并且在此过程中以某种方式丢失了rails。 我不知道为什么。 现在每次我尝试再次加载它时,我得
2回复

如何在Gemfile中指定本地gem的版本?

我有一个本地gem和使用该本地gem的Rails应用程序。 有没有办法指定gem的特定版本? 我知道'rake install'在gem的/ pkg目录中生成* .gem。 但是我不知道如何使用它。 这是我现在使用的方式: 谢谢。 山姆 编辑: 我认
1回复

Rubygems:指定对gem最新版本的依赖

我正在开发依赖于另一个宝石B的宝石A。我需要宝石的用户才能拥有B的最新版本。 所以我想在我的gemspec中说 原因是B包含一个数据库驱动程序,该驱动程序必须为最新版本,否则数据库将拒绝连接。 所以换句话说,我需要在使用我的宝石之前强制gem update宝石。 有没有办法在g