繁体   English   中英

在Linode Ubuntu上安装InfluxDB

Installing InfluxDB on Linode Ubuntu

提示:本站收集StackOverFlow近2千万问答,支持中英文搜索,鼠标放在语句上弹窗显示对应的参考中文或英文, 本站还提供   中文繁体   英文版本   中英对照 版本,有任何建议请联系yoyou2525@163.com。

我在Linode上有一个32位Ubuntu,通过以下方式确认:

~$ uname -m
i686

按照安装说明,我得到:

~$ wget https://s3.amazonaws.com/influxdb/influxdb_latest_i686.deb
...
Length: 16572810 (16M) [binary/octet-stream]
Saving to: `influxdb_latest_i686.deb'
100%[======================================>] 16,572,810  2.43M/s   in 7.3s
2015-03-31 15:59:28 (2.16 MB/s) - `influxdb_latest_i686.deb' saved       

~$ sudo dpkg -i influxdb_latest_i686.deb
dpkg: error processing influxdb_latest_i686.deb (--install):
package architecture (i686) does not match system (i386)
Errors were encountered while processing:
influxdb_latest_i686.deb

我也尝试了amd64软件包,并得到了相同的错误。

有任何想法吗?

1 个回复

InfluxDB不再提供i386二进制文件,您需要从源代码进行编译。 我设法用dpkg -i --force-architecture influxdb_0.8.8_i686.deb安装了0.8,但0.9无法正常工作

https://influxdata.com/downloads/

关于32位软件包

业界正在逐渐摆脱对32位x86架构的支持,因此我们不提供打包的32位二进制文​​件。 但是,我们会尽力确保可以始终为32位x86架构编译源。 为此,除了主要的64位版本外,我们的CI系统当前还编译32位二进制文​​件并针对32位版本运行单元测试套件。 如果针对32位体系结构的编译或单元测试失败,我们将对其进行修复。

1 在Ubuntu16.04上安装InfluxDB的问题

我正在尝试在Linux服务器上安装InfluxDB。 我运行sudo apt-get install influxdb并获得以下输出: 然后,要检查influxd的版本,我运行了influxd并获得了版本号0.10.0。 最新版本是1.7.3。 因此,我使用以下sudo apt-g ...

3 Linode Ubuntu 16 for PHP 5?

我试图在Linode上安装PHP 5.x,但出现错误: E:软件包“ php5-fpm”没有候选安装 命令行是 须藤apt-get install php5-fpm ...

2016-07-20 02:11:28 2 174   linode
4 在Linode服务器上安装Ruby

该linode 指南提供了有关如何在服务器上安装ruby的说明。 该指南使用ruby 1.8,它与其他依赖项一起安装。 如何更改这些命令以设置ruby 1.9.2? 依赖关系似乎相互链接。 Linode指南的命令: 安装Ruby依赖项 apt-get install wge ...

5 在ubuntu上启动influxdb控制台

我已经下载了influxdb 1.2.0的tar文件,并将其解压缩到一个文件夹中,在配置文件中,我分别将admin和HTTP端口启用了8083和8086。我还在usr /中运行了influx和influxd服务bin部分,但是当我点击// localhost:8083时,管理面板未显示在浏览器中 ...

6 在Kubernetes集群上安装InfluxDB

我一直想在我的Kubernetes集群(使用kubeadm构建)上快速安装InfluxDB。 这只是在节点上运行的单个pod(因为非企业InfluxDB不支持群集)。 我一直想将数据持久化到托管Pod的任何节点上(即Kubernetes提供的hostPath解决方案)。 我是Kuber ...

8 Certbot与Tomcat9(linode)Ubuntu 19.4

我使用let的加密在apache http服务器(端口80)和webmin(端口10000)上设置了https。 我已经在同一台服务器上安装了tomcat9,它正在侦听端口8080(http)。 tomcat9服务器也可以正常工作。 我正在尝试为tomcat9设置https。 我已将/e ...

暂无
暂无

声明:本站的技术帖子网页,遵循CC BY-SA 4.0协议,如果您需要转载,请注明本站网址或者原文地址。任何问题请咨询:yoyou2525@163.com.

 
粤ICP备18138465号  © 2020-2022 STACKOOM.COM