Dart Editor版本1.10.0.release(稳定)Dart SDK版本1.10.0

pubspec.yaml

name: project
description: A sample Polymer application
dependencies:
  browser: any
  polymer: any
  observe: any
  bwu_datagrid: any
transformers:
- polymer:
   entry_points: web/project.html

运行pub get

--- 19:11:03 Running pub get on C:\Users\Toshiba\Documents\Dart\project ... ---
Pub get failed, [1] Resolving dependencies...
Incompatible version constraints on barback:
- observe 0.9.1+1 depends on version >=0.9.0 <0.11.0
- pub itself depends on version >=0.13.0 <0.15.3

** Warning: Application may fail to run since packages did not get installed.Try running pub get again. **

我不明白observe我在项目中使用的对象与pub本身之间有什么联系。 你有什么主意吗?

  ask by user3103137 translate from so

本文未有回复,本站智能推荐:

2回复

发布错误:分析仪的版本不兼容

我有一个很奇怪的问题。 在添加新的依赖项之前,我有一些依赖项可以很好地工作,但是一旦添加新的依赖项(在此特定情况下为async_await ),我就会在使用pub get时pub get Incompatible version constraints on analyzer错误的Incomp
2回复

AngularDart对聚合物的不兼容版本限制

我有一个Dart项目,其中包含聚合物,还有一个简单的Polymer元素fancy_button。 我想添加AngularDart,因此可以通过将包添加到我的pubspec.yaml来实现,如下所示: 当我尝试pub get以下奇怪的版本约束问题: 我不明白
1回复

Android和Flutter引擎中的Dart版本不同

我的Flutter Engine使用Dart 2.5版,而Android Studio中的Dart似乎具有Dart 2.6.1。 在开发任何项目时是否存在任何潜在的问题? 如何确保两者相同? 请问我如何降级版本? 在此处输入图片说明
1回复

dart聚合物和hangouts_api不兼容的版本

我试图同时使用dart hangouts_api和Polymer,但出现以下错误: 浏览器不兼容的版本限制: -hangouts_api 0.3.0取决于版本> = 0.9.0 <0.10.0 -聚合物0.15.1取决于版本> = 0.10.0 <0.1
1回复

Dart版本2.0.0-dev.64.1不兼容的快照

我刚刚安装了Dart版本2.0.0-dev.64.1,当使用Dart VM在WebStorm中运行测试时,我得到错误: 快照与当前VM配置不兼容:快照需要'发布no-strong no-type_checks no-asserts no-error_on_bad_type no-err
1回复

由于intl的版本不同,因此无法使用jiffy和flutter_localizations

我正在尝试使用Jiffy包和flutter本地化包。 现在的问题是,两者都使用intl包,但是版本不同。 当我尝试“ Package get”时,出现以下错误: 由于sdk的flutter_localizations的每个版本都取决于intl 0.15.8,jiffy的每个版本都取
1回复

Shadow DOM“调试”适用于Firefox,但压缩版本不是吗?

http://pub.dartlang.org/packages/shadow_dom 在Firefox中,包括调试版本对我来说都行得通,但缩小版本不行。 我有什么理由不应该在生产中使用调试版本? 我目前似乎没有太多选择。 有人遇到过这种情况么? 如果有问题,我正在使用an
1回复

升级Flutter软件包后,Android版本不再起作用

我刚刚更新了一些Flutter软件包。 但是,在进行颤振运行时,我总是收到此错误。 如果我将apk直接安装到设备上,则可以正常工作(这意味着我可以进行flutter build apk),但是,在调试模式下运行不会很幸运。 最初,我发布了一个multidex问题,我认为是通过将buil
3回复

安装build_runner时Dart SDK版本不匹配

我正在尝试将build_runner: ^1.10.2添加到dev_dependencies,但是出现以下错误: The current Dart SDK version is 2.9.0. Because project_name depends on build_runner >=1.1
1回复

如何确定Google服务插件,gradle插件和dart pub软件包的兼容版本

我正在学习颤动。 “ 添加Firebase到Flutter ”教程显示了如何使用此功能。 “ com.google.gms:google-services:3.2.1”,但最新版本似乎是4.2.0 另外,我想使用https://pub.dartlang.org/packages中合适(