我的Xcode项目可以在设备上构建和运行,但不能在模拟器上构建。 我在项目中使用了自定义框架。 这篇文章似乎表明,当您构建要包含在另一个项目中的框架时,只能为模拟器或设备构建框架,而不能同时为两者构建。 是这样吗

我正在使用Xcode 6.3.1

===============>>#1 票数:1

您是正确的,一次只能为一个平台构建,但是链接中的答案说明了如何使用脚本来构建包含两个平台的框架的二进制文件。

  ask by mattnedrich translate from so

未解决问题?本站智能推荐:

1回复

在设备上运行时,iOS8 Beta 3 SpriteKit exc_bad_acces

我目前正在使用Swift在Spritekit开发一个应用程序。 该应用程序在设备和模拟器中完美运行,直到我更新到Xcode 6 Beata 3和iOS 8 Beta 3.当我在模拟器中运行应用程序时,一切仍然完美。 但是当我创建exc_bad_acces时,在设备上运行应用程序会导致SKTe
6回复

未安装所选设备的运行时错误

我试图在ios8模拟器上使用xcode 6运行应用程序,但是出现错误"The runtime for selected device is not installed ". 我将命令行工具设置为首选项,但没有运气。 请帮忙。
2回复

UICollectionview内置于Xcode 6中,但在iOS 7中运行时不显示

运行应用程序内置Xcode 6.0.1时出现问题, UICollectionView仅显示单元格,但不显示图像,标签内容。 但是在iOS 8中运行时,它可以正常工作。 我不知道为什么 您能帮我解决这个问题吗?
1回复

用户在5.0之前的iOS版本上定义的运行时属性

我有一个现有的iOS项目,我正在维护,我需要升级到最新的Urban Airship SDK(5.0.2)。 该项目使用CocoaPods,因此下拉最新版本就像pod 'UrbanAirship-iOS-SDK', '~> 5.0.2' Podfile ,但是现在构建时,我收到下面的编译错
6回复

Xcode 6.1中的iOS 8.1模拟器运行时不可用错误

到目前为止,我一直在使用Xcode 6.0.1,一切都很好。 然后我升级到Xcode 6.1并尝试在iPhone 6模拟器中运行我的应用程序(其部署目标为7.0)。 但它显示一条错误消息: iOS 8.1模拟器运行时不可用 。 从Xcode首选项的下载部分下载iOS 8.1模拟器
1回复

如何使用XCode 6构建iOS框架

我知道熟悉的教程 ,但是框架XCode 6模板的引入改变了游戏。 我已经观看了WWDC 2014关于构建现代框架的视频 ,但它更多地讨论了在单个项目中构建扩展,框架和应用程序。 它没有指定我使用它构建的框架是否真正可以在任何项目中重用。 我正在构建XCode 6方式的框架(文件 -
1回复

应用程序运行时,在故事板上设置的iOS UITableView行高加倍

这一定是最愚蠢的问题,并且我确定它已经在一些基础教程中涵盖了,但是这里是: 我正在使用Xcode 6,并在情节提要中创建一个新的UITableView。 我得到的默认行高为44。每当我使用模拟器以及任何iPhone 4s,5、5s和6运行应用程序时,我的行高都会更改为88! 对于iPh
1回复

当应用程序在我的设备(iPhone 6)上快速运行时,“没有可用的源1类型”

这突然之间,但是当我运行以下方法时,它会抛出“没有可用的源1类型”错误,我看了每个地方,人们说它在模拟器中很好我在iPhone上运行它6.任何线索为什么?
2回复

在应用程序运行时在AppDelegate中运行didFinshLaunchingWithOptions吗?

有什么办法可以执行 应用程序从其他ViewController运行时该方法如何?
1回复

对UIAlertController进行子类化并遇到运行时错误

我是iOS和OSX编程的新手,并决定从Swift开始,将iOS8 API用于测试应用程序,并尝试在其他环境中使用的一些编程技术。 但是,我遇到了一个奇怪的情况,我希望有人可以识别和帮助我。 这涉及对UIAlertController进行子类化的困难。 这是我的第一次尝试: 但是