我用作曲家安装后,在zend Framework 2中为mysql Groupconcat使用了beberlei教义扩展,我从问题中更改了这样的设置:

如何在Zend Framework 2中实现beberlei学说扩展

 'configuration' => array(
        'orm_default' => array(
            'string_functions' => array(
               'GroupConcat' => 'DoctrineExtensions\Query\Mysql\GroupConcat'
            )
        )
    ),

在我的本地PC上一切正常,但是当我在远程服务器上上传代码时显示此错误:

Fatal error: Class 'DoctrineExtensions\Query\MySql\GroupConcat' not found in **/www/vendor/doctrine/orm/lib/Doctrine/ORM/Query/Parser.php on line 3389

我更新了代码相同的所有内容,我使用composer安装并安装了composer,并更新了远程服务器上的所有内容,确保代码相同并且composer安装了所有内容

  ask by babak faghihian translate from so

本文未有回复,本站智能推荐:

1回复

ZF2中的beberlei DoctrineExtensions在Windows localhost上运行正常,但显示致命错误Linux生产服务器

我想在ZF2中使用DoctrineExtensions的Day,Week,Month和Year函数,并收到以下错误消息。 该代码在Windows上运行的本地计算机上运行正常,但在Linux上运行的服务器上无法运行相同代码。 这是我的module.config.php配置 我使用
1回复

如何在Zend Framework 2中配置doctrine扩展?

我已将此行添加到我的composer.json中: 这是在我的模块的module.config.php中: 然后我想在我的实体中使用带时间戳的注释,例如: 但这不起作用。 当我使用上面的注释持久化实体时,创建和更新的列为NULL。
1回复

doctrine-extensions可上载,如何在Zend Framework 2中使用?

我在项目中集成了学说扩展。 时间戳可作为示例。 但是如何使用“可上传”行为? 我读了这份文件 。 他们正在写有关使用$listener的用法部分 ,但是我如何得到这个变量? 在我的控制器或服务中? 它从何而来? 感谢您的任何建议...
1回复

YEAR()和beberlei / DoctrineExtensions

我必须使用YEAR进行请求,并使用doctrine命令安装了beberlei / DoctrineExtensions。 我添加了请求的注释 ,但不起作用,出现此错误: 尝试从命名空间“ DoctrineExtensions \\ Query \\ Mysql”中加载类“ Y
2回复

DoctrineExtensions(Beberlei)不起作用-Doctrine 2

我安装了Beberlei DoctrineExtensions,但无法使mysql的YEAR和YEAR正常工作。 我的自动装带器中有这个: 当我尝试执行以下dql语句时 我收到以下错误:错误:预期的已知函数,在/usr/local/lib/php/Doctrine/ORM/
1回复

DoctrineExtensions错误

我想配置https://github.com/Atlantic18/DoctrineExtensions与指令https://github.com/l3pp4rd/DoctrineExtensions/blob/master/doc/annotations.md#em-setup 但是我得
1回复

DoctrineExtensions在错误的目录中查找

我在PHP项目中使用Doctrine ORM。 在我的一个查询中,我正在使用'COS'(余弦)和'SIN'(正弦)函数,为了在教义上实现这一点,我必须将其添加到我的objectmanager配置中: 当我在本地PC +服务器上运行它时,此方法工作正常。 但是,一旦将项目放到在
2回复

在ZF2中可翻译的DoctrineExtensions-如何以及在哪里设置DefaultLocale

我坚持使用TranslatableListener的$ defaultLocale。 https://github.com/Atlantic18/DoctrineExtensions/blob/master/doc/translatable.md#default-locale 我发现
2回复

在Symfony 2项目中安装Doctrine扩展会导致致命错误

问题在于:我没有成功安装symphony 2的doctrine扩展,特别是timestampable。 我按照本教程 我如何进行: 我在deps文件中添加以下行: 然后我进入该行 一切都很好。 然后我激活相关文件中的扩展名 最后,我添加了注释我的实体
2回复

安装stof捆绑包和学说扩展(树)时发生致命错误

问题出在这里:我没有成功用Symphony 2.0安装stof bundle 我如何进行: 我在deps文件中添加以下行: 然后我运行命令 php bin / vendors install-重新安装 一切都很好。 然后我在相关文件中激活扩展名