我想使用Eclipse groovy批处理编译器在IntelliJ IDEA中编译Groovy。 但是,我一直在努力寻找可靠的文档,以了解如何使其正常工作或期望得到什么。

天真的,我从Maven Central下载了最新的批处理编译器:

    <dependency>
        <groupId>org.codehaus.groovy</groupId>
        <artifactId>groovy-eclipse-batch</artifactId>
        <version>2.4.3-01</version>
    </dependency>

然后,我在IDEA设置中设置了Java编译器以使用它:

Build, Execution, Deployment -> Compiler -> Java Compiler
    Use Compiler: Groovy-Eclipse
Path to groovy-eclipse-batch jar:
    /tmp/groovy-eclipse-batch-2.4.3-01.jar

当我要求IDEA编译项目中的groovy文件(以前使用groovy编译器进行编译)时,它只会为每个文件返回此错误:

Error:(1, -1) Groovy-Eclipse: Groovy:Internal groovy compiler error. 

我在任何IDEA日志文件中都找不到重要的内容。

有人有工作正常的IDEA / groovy-eclipse-batch环境吗? 我缺少任何陷阱吗?

#1楼 票数:0

Bintray提供了更新的Groovy-Eclipse编译器工件。 它们包含许多错误修复以及与Java 9,配置脚本,InvokeDynamic等的兼容性。

https://bintray.com/groovy/maven/groovy-eclipse-batch

  ask by Dr Joe translate from so

未解决问题?本站智能推荐:

1回复

使用Groovy-Eclipse编译器插件的Maven构建在jar中包含* .groovy文件

我为Eclipse RAP项目设置了Maven构建。 该项目包含Java和groovy。 Maven构建可以正常工作,但是生成的JAR包含大多数类的已编译类文件和 groovy源文件。 我只希望编译的类文件。 不是一个普通的程序员,我迷路了。 在eclipse中使用warexp
1回复

Eclipse 上的 Groovy 编译器不再包含 2.4 版

我需要再次设置我的 Eclipse IDE,不像我第一次设置它时我遇到了 Groovy 软件的问题。 我需要 Groovy 编译器 2.4 版,但只能在 2.5、3.0 或 4.0 之间进行选择。 我使用了与上次相同的位置: https : //dist.springsource.org/relea
3回复

Maven:Groovy-Eclipse编译器插件,带有Groovy 2.3.5

由于GMaven已经停产,我一直在我的Maven项目中使用Groovy-Eclipse Compiler插件 。 我使用的版本是2.8.0-01,我特别使用了Groovy 2.1。 我知道2.9.0-01-SNAPSHOT已经出去的时间最长,但是当它正式发布时没有ETA。 我的问题是.
2回复

如何将Groovy-Eclipse与特定的Groovy编译器一起使用?

根据groovy-eclipse插件网站 ,groovy-eclipse插件支持某些groovy版本,即1.8、2.0和2.1。 这对我来说似乎有些局限。 如果我使用groovy 1.9或1.7应该怎么办?
2回复

马文。 无法使用 groovy-eclipse 编译器编译模块

我正在尝试将我的项目从 java 8 迁移到 java 11。我在 root pom.xml做了什么: 已更换 和 配置好的 maven-toolchain-plugin 之后那些不使用 groovy 的模块编译没有问题。 但是这个项目中很少有模块使用 groovy。
1回复

升级 eclipse 后 Groovy 失败

最近升级到 Eclipse 2020-12 (4.18.0) 并且 Groovy 从那以后就没有工作了。 升级的 Groovy 没有任何改进。 现在正在运行(展开所有“安装了什么”树) Eclipse Groovy 开发工具 org.codehaus.groovy.eclipse.fea
2回复

groovy-eclipse-compiler 编译但 javac 编译失败

我的项目使用 groovy-eclipse-compiler 成功构建,但在没有 groovy-eclipse-compiler 的情况下失败(仅使用 javac)。 构建失败并显示如下错误消息(在测试类中报告,同时模拟调用) 为了调试问题,我创建了一个包含最少文件的项目(如下所示)。 虽然在项
1回复

如何调试直接在Eclipse中运行的GroovyScripts

我正在尝试直接在Eclipse中调试简单的GroovyScript,但从未触发断点。 我仅使用Codehaus Groovy-Eclipse插件,是否需要配置超出默认值或使用其他插件进行调试?