我正在使用4.5.5版的jhipster。 我的操作系统是Linux Mint。 我正在使用IntelliJ作为我的IDE。

就生成代码,构建和运行代码而言,一切工作正常。

客户端不幸的是,当我对客户端代码(html或ts)进行更改时,直到我重新编译客户端代码完成后,更改才会反映出来。 为此,我要做“ mvn -Pdev,webpack”。 重新启动客户端需要花费相当长的时间,这确实使我退缩了。

热部署我期望发生的事情是我可以运行“ npm start”,并且当我将更改保存到ts或html文件中时,它将被选中,并且该更改将立即在浏览器中可见。

问题

有什么想法为什么客户端热部署不起作用?

有什么想法可以确定问题出在哪里吗?

例如,如何知道热部署正在监视哪些文件夹?

谢谢您的帮助。

我确信其他人也会遇到同样的问题,并且会很高兴地阅读答案。

亲切的问候,Fergal。

PS需要任何详细信息,只需询问。

#1楼 票数:0 已采纳

弄清楚了。

其他人在全球安装的webpack实例中也有类似的问题。

我安装了本地版本,并且文件更新正在检测和重新编译,并且应用程序正在热部署。 现在工作正常。

要安装本地版本webpack.js.org/guides/installation/#local-installation。

  ask by fergal_dd translate from so

未解决问题?本站智能推荐:

1回复

Jhipster-生产构建失败

我无法通过运行mvnw -Pprod生成JHipster应用程序战争。 这是我在控制台中遇到的错误: https : //pastebin.com/3wLwy2x4 还有我的package.json依赖项: https://pastebin.com/txnATG6M 解决方案: J
1回复

在本地运行Jhipster注册表,而无需浏览器同步

我正在尝试使用JHipster构建微服务应用程序。 我正在关注本教程 。 我已经在本地成功运行了jhipster-registry(我已经克隆了它,然后运行./mvnw命令,然后yarn start查看已注册的应用程序)。 没有这个开始,我将无法在浏览器中看到任何内容。 但是我想用浏
1回复

将JHipster应用程序转换为gradle,现在在dev中返回空白页

我有一个用maven生成的JHipster应用程序,我只是将其转换为gradle。 我删除了该项目,使用gradle重新生成了该项目,然后遍历了所有更改。 在启动项目( ./gradlew )后,当我在localhost:8080进入页面时,我得到了一个空白页面。 当同时运行./g
1回复

部署到Istio(使用Kubernetes)的Jhipster无法正确加载

我正在将 Jhipster 应用程序部署到 Kubernetes 环境,并使用 Istio 进行网络连接。 下面是我的 VirtualService。 请注意,当前prefix设置为/ ,一切正常。 但是我有几个应用程序在这个集群上运行,所以我需要将它映射到/mywebsite 。 当我访问该应用程
5回复

Jhipster:不能使用jhipster-generator

我想尝试新版本的jhipster,但我无法生成示例项目。 我有一个jhipster错误: 我按照Jhipster文档中的建议安装了npm,yo,bower,generator-jhipster。 generator-jhipster安装: - 我不明白发生了什么。 发生器
1回复

使用VisualStudioCode调试JHipster前端

我已将Debugger for Chrome扩展安装到 VS Code。 如何调出在调试模式下使用 webpack 的 JHipster Angular 应用程序? JHipster Angular 在<application>/src/main/webapp/app ,webpack
1回复

如何在PrimeNG6+中使用JHipster5+

我试过了: PrimeNG官方入门指南 将PrimeNG与JHipster集成的步骤 (很抱歉,如果这是重复的帖子,那里没有人对此发表评论) 发电机jhipster-primeng 以及其他一些文章和stackoverflow帖子,都没有让最新的PrimeNG 6+与最新的
1回复

npm不匹配?为什么“yogenerator-jhipster”在我的数据库选项中不显示oracle?

最新版本的jHipster提供了与我的命令提示符中显示的选项不同的选项。 我想知道为什么我缺少诸如oracle数据库选项之类的东西? 有人有什么想法吗? 进行npm list generator-jhipster演示实际上我确实具有最新版本。 这是我应该看到的: 我应该看到的 与