我根据本文将我的ASP.NET Core 1.1 Web应用程序升级到ASP.NET Core 2.0: https : //docs.microsoft.com/zh-cn/aspnet/core/migration/1x-to-2x/

我遵循了每个步骤,现在遇到了NuGet错误-参见下文: 在此处输入图片说明

知道为什么吗?

#1楼 票数:0

我曾经遇到过类似的问题。 请尝试以下几种方法之一:

  1. 清理解决方案,删除解决方案文件夹中的所有bin和obj文件夹,重新生成
  2. 升级Visual Studio
  3. 从%temp%文件夹中删除所有。 (这对我有用)

#2楼 票数:0 已采纳

升级到Visual Studio 2017 15.7.1的最新稳定版本为我解决了此问题。

  ask by Sam translate from so

未解决问题?本站智能推荐:

1回复

将ASP.NETCore1.1升级到ASP.NETCore2.0

在ItemGroup元素下的csproj文件中,我引用了各个包 - 都指向1.1。 在本文中,概述了升级到ASP.NET Core 2.0的步骤, https://docs.microsoft.com/en-us/aspnet/core/migration/1x-to-2x/ ,在“更新程序
2回复

ASP.Net核心错误JSON

我正在使用ASP.NET Core。 我正在创建一个基本的webapi。 有问题时,我想显示JSON错误。 屏幕上显示我想要的打印屏幕。 唯一的问题是它发送的状态码为200。 我可以这样解决: 但是我不喜欢这样,因为现在您可以使用NotFound指定状态码500。 有人
6回复

从ASP.NET5Beta4升级到Beta5时出错

我已按照此处的步骤从ASP.NET 5 Beta 4升级到Beta 5,但在调用application.UseBrowserLink();时在运行时收到错误application.UseBrowserLink(); : mscorlib.dll中出现“System.TypeLoadExc
1回复

恢复包时ASP.NET5上NPM出现错误

在ASP.NET 5(vNext)项目上还原NPM软件包时,出现以下错误/警告: 这是我可以解决的问题,还是ASP.NET 5的问题?
1回复

500内部服务器错误,带有基于策略的身份验证asp.net核心

我正在尝试在asp.net core 2.1中进行基于策略的身份验证。 由于依赖项注入I,面临500个内部服务器错误。 无法弄清楚如何解决该问题。 这是权限检查代码 权限枚举 该错误是由services.AddSingleton<IAuthorizationHandler,
1回复

ASP.NET核心通配符路由除外

我正在使用ASP.NET Core来提供这样的SPA: 我的JSON端点位于同一个应用程序中,路由如下: 这很好,除了当我尝试调用端点api/something/that/doesnt/exist我得到了索引页面,当我真正想要404时。 是否可以设置[<Route("{*url
4回复

使用逗号的Asp.Net表单输入

我有一个输入收集一美元金额的表格(例如: $5,000 ) 如何允许$5,000的输入不触发(!ModelState.IsValid)删除逗号( , )和$ for POSTing? 视图模型 视图 调节器
5回复

asp.net核心默认代理

在 net 4.5 中,我们正在使用这样的代理: 但是在asp.net core或test中我们找不到像上面这样的解决方案有人可以帮我吗? 我真的很感谢你的帮助感谢和问候