您好,当我下载课程中提供的代码时,我正在遵循Udacity的材料设计课程,但是当我在Android中打开它时,会出现此错误

Error:Could not find com.android.tools.build:gradle:2.2.3.
Searched in the following locations:
    https://repo1.maven.org/maven2/com/android/tools/build/gradle/2.2.3/gradle-2.2.3.pom
    https://repo1.maven.org/maven2/com/android/tools/build/gradle/2.2.3/gradle-2.2.3.jar
Required by:
    :ApplyPaletteDemo:unspecified

#1楼 票数:0 已采纳

检查项目的build.gradle文件是否与您的Android Studio版本匹配。 该项目可能是为旧版本的Android Studio编写的。

    buildscript {
    repositories {
        jcenter()
    }
    dependencies {
        classpath 'com.android.tools.build:gradle:2.3.3'

        // NOTE: Do not place your application dependencies here; they belong
        // in the individual module build.gradle files
    }
}

allprojects {
    repositories {
        jcenter()
        maven{
            url "http://maven.google.com"
        }
    }
}

  ask by Abd EL Magied translate from so

未解决问题?本站智能推荐:

2回复

找不到com.android.tools.build:gradle:2.2.3

我正在构建一个react native应用程序,我正在使用react-native-gallery-manager库。 没有它它工作正常,但有了它我得到以下错误: *什么地方出了错: 配置项目':react-native-gallery-manager'时出现问题。
2回复

React Native:找不到com.android.tools.build:gradle:2.2.3

我正在使用本机做一个Android应用程序,这是我得到的错误: 我也收到以下警告: 这是我的build.gradle文件: 这是我的gradle包装器分发URL: distributionUrl = HTTPS://services.gradle.org/dis
2回复

找不到 com.android.tools.build:gradle:4.0.1

错误 : 找不到 com.android.tools.build:gradle:4.0.1。 在以下位置搜索: https://jcenter.bintray.com/com/android/tools/build/gradle/4.0.1/gradle-4.0.1.pom http
1回复

cordova gradle 6.0.1 错误“找不到 com.android.tools.build:gradle:6.0.1”

我正在尝试使用cordova在本地构建我的Android应用程序。 我已经下载了最新的 gradle 版本,但在导出时出现此错误: 这是 build.gradle 构建脚本: 我的gradle-wrapper.properties还指出distributionUrl设置为http\\://s
1回复

找不到 com.android.tools.build:gradle:3.2.1。 在来自 github 的示例项目中

我正在尝试编译这个项目: https : //github.com/dakatso/SpeexExample 该项目在 gradle 同步期间给出了错误(它说没有找到名为mipsel-linux-android东西)。 我对以下文件进行了更改: gradle-wrapper.propertie
1回复

找不到参数的方法 classpath() [com.android.tools.build:gradle:4.0.0

无法在 org.gradle.api.internal.artifacts.dsl.dependencies.DefaultDependencyHandler 类型的对象上找到参数 [com.android.tools.build:gradle:4.0.0] 的方法 classpath()。 我的
1回复

“找不到 com.android.tools.build:gradle:2.2.0。” android studio 中的错误

错误 导入从 Web 下载的项目后,我开始收到此错误。 看到这个答案后,我添加了上述文件 但我仍然收到错误。 我试过Inavalidate caches/restart , clean and rebuild project , sync gradle 。 出于某种原因, Add googl