我希望你能帮助我 。 我对Node相当陌生,正在构建我的第一个Node应用。

我已经在node.js中构建了一个应用程序。 在本地运行时,它可以正常运行并按预期运行。
尝试在内部生产服务器上运行它时,出现错误消息。 有问题的错误消息

开头模板文字标签似乎出现了问题。 有问题的文件使用简单的模块导出功能。 我将代码简化了一些,以使其更易于阅读。 见下文:

  exports.templateModule = function(markup, edmData) { var template = `<!DOCTYPE html> <html xmlns="http://www.w3.org/1999/xhtml"> <head></head> <body></body> </html> `; return template; 

我正在使用节点版本v6.11.0。

生产服务器在Linux上运行。

下面的package.json文件可以帮助您。

{
  "name": "template",
  "version": "0.0.0",
  "description": "A simple tempate test.",
  "main": "app.js",
  "scripts": {
    "start": "node app.js"
  },
  "dependencies": {
    "ejs": "^2.5.6",
    "ejs-lint": "^0.3.0",
    "express": "4.15.2",
    "glob": "^7.1.2",
    "node-dev": "^3.1.3"
  },
  "repository": {
    "type": "git",
    "url": "https://github.com/heroku/node-js-getting-started"
  },
  "license": "MIT",
  "devDependencies": {
    "node-dev": "^3.1.3"
  }
}

如果可以的话,我会提供您需要的其他信息。

任何帮助或见解将不胜感激。
谢谢

#1楼 票数:2 已采纳

模板字符串已添加到NodeJS v4.0.0中

Node.js v4.0.0包含V8 v4.5,与今天的Chrome网络浏览器一起提供的V8版本相同。
这为Node.js用户带来了很多好处,最值得注意的是,许多ES6新功能默认启用,包括块作用域,类,类型数组(Node的Buffer现在由Uint8Array支持),生成器,Promises,Symbols, 模板字符串 ,集合(地图,集合等),以及V8 v4.5新增的箭头功能。

如果您在生产服务器上使用的是Node.js的旧版本,请考虑将其升级到最新版本。

  ask by Moe-Joe translate from so

未解决问题?本站智能推荐:

1回复

您的SQL语法有错误;检查与您的MariaDB服务器版本相对应的手册以获取正确的语法

每当我尝试测试我的数据库端点时出现错误,它显示“代码”:“ER_PARSE_ERROR” 所以这是我的 mysql 数据库模型: 它给了我这个错误: 来自邮递员的错误信息但是如果我改变了 branch_id 之前的最后一行,这是这个的纬度 它会很好地传递数据,那么这里可能是什么问题?
1回复

在第1行的\\'\\'testusername\\'\\'附近使用正确语法的服务器版本}

所以我尝试在sql数据库上保存一些数据(用户数据),但出现此错误。 我尝试加上一些引号等。 但是当我尝试出现此错误时,您能帮我吗? 谢谢 错误:“您的SQL语法有误; 检查与您的MariaDB服务器版本相对应的手册,以在第1行的'testusername'附近使用正确的语法'}
1回复

如何修复MongoError:不支持的服务器版本?

我正在尝试使用MongoDB运行Node.js服务器。 我密切关注了这些教程。 这是我的app.js文件: `但是,当我尝试运行它时,出现以下错误: 我怎样才能解决这个问题? 我的package.json文件说我正在使用版本^ 3.0.0-rc0。 我似乎无法在线找到任何解决方案
1回复

哪个是获得部署服务器版本的最佳方法?

我通常使用package.json的version字段跟踪服务器版本。 有时,使用/version路由来快速检查已部署的版本确实很有用。 我正在考虑这样做: 有没有更好的方法(最干净,跨平台,最简单,合乎逻辑)?
2回复

MongoError:驱动程序与此服务器版本不兼容?

这取决于我的程序: 这个查询在mongo 2.6的nodejs中工作正常 但是将mongo 2.6升级到3.x时会出现错误: MongoError:驱动程序与此对象版本在__executeInsertCommand(/home/ekodev/Documents/ComParice/
1回复

MongoError:驱动程序与此服务器版本不兼容

我刚刚安装了Mongo,Node等,当我尝试通过我的nodejs服务器更新数据库时,我收到此错误: 以下是我的版本: 节点 v0.12.2(最新版本为v0.12.3) Express v4.12.4(最新版本是v4.12.4) Mongodb v3.0.3(最新版本是v3.
1回复

Express服务器未在我的React生产版本上运行

我有一个用 create-react-app 制作的 React 应用程序,我试图在快速服务器上运行它。 它在运行npm start时工作正常,但是在运行npm run build然后serve -g build我只能连接到本地主机上的端口 5000 而不是我在快速服务器中设置的 8080。 服务
1回复

使用?从节点/快速服务器执行mysql查询占位符得到语法错误|npmmysql包

我似乎无法理解这一点。 我有一个正确设置的连接,并且能够从前端从我的数据库中获取数据,但是我认为某些语法有问题。 我有用户输入存储在“searchTerm”中,我试图使用占位符运行查询?。 我遇到问题的代码是 问题不在于查询,因为它在工作台中得到了肯定的结果,并且当我对用户输入的值进行硬编码时也能正