繁体   English   中英

推送插件注册失败

Push Plugin register failed

提示:本站收集StackOverFlow近2千万问答,支持中英文搜索,鼠标放在语句上弹窗显示对应的参考中文或英文, 本站还提供   中文繁体   英文版本   中英对照 版本,有任何建议请联系yoyou2525@163.com。

我已经安装了phonegap-push-plugin,用于向Android和iOS设备发送推送通知。

android没问题,但是当我在iPhone上尝试时,我可以在设备控制台中看到一些错误。

当我尝试init(); 结果进入设备控制台是:

Push Plugin register failed
4.13.0 - [Firebase/Messaging][I-FCM012002] Error in application:didFailToRegisterForRemoteNotificationsWithError: aucune autorisation « aps-environment » valide détectée pour l’application

我进行了很多搜索,但是我发现没有什么对我有帮助,因此我现在向社区提出要求。

我使用Phonegap build cli 8.0.0构建应用程序。插件为:master分支上的https://github.com/phonegap/phonegap-plugin-push

推送插件config.xml部分:

<plugin name="phonegap-plugin-push" source="npm">
    <param name="SENDER_ID" value="123456789" />
</plugin>

我使用FCM和正确的推送证书发送通知,并且我认为发送通知的Web服务正常工作,导致他可以完美地为android分支工作。

iPhone 5c(A1456)iOS 10.3.3。

感谢您的未来帮助。

1 个回复

检查是否在Xcode的“ 常规”部分中启用了“ 推送通知”功能。

还要重新检查这篇文章中的所有建议: Cordova上的Firebase不会在iOS设备上触发通知

1 iOS VoIP推送 - 无法注册

功能 没有被召唤。 这是我的代码: 我读到这可能是证书问题所以 创建了新的应用ID,个人资料和证书 为应用添加了背景功能 使用以下代码签署代码:代码签名身份 - iPhone分发,配置文件VoIPPushTestProfile 我正在归档代码并 ...

4 phonegap-plugin-push不注册

我正在学习如何使用phonegap制作应用程序,并且尝试从此处使用phonegap推送插件,问题是在初始化它后,不会触发register事件,我执行了以下步骤 用phonegap创建项目 按照说明使用phonegap plugin add phonegap-plugin-pus ...

10 无法将推送通知插件添加到cordova

我刚刚创建了一个测试 cordova 项目,现在正在尝试将一个简单的推送通知插件 ( https://github.com/phonegap-build/PushPlugin ) 添加到我的项目中。 我按照它的指示输入了这个: 但立即,命令行失败并显示以下错误消息: 我刚刚更新了我的 To ...

暂无
暂无

声明:本站的技术帖子网页,遵循CC BY-SA 4.0协议,如果您需要转载,请注明本站网址或者原文地址。任何问题请咨询:yoyou2525@163.com.

 
粤ICP备18138465号  © 2020-2022 STACKOOM.COM