繁体   English   中英

无法解决:尝试添加Firebase身份验证时出现firebase-auth-15.0.0错误[重复]

Failed to resolve: firebase-auth-15.0.0 error when trying to add Firebase authentication [duplicate]

提示:本站收集StackOverFlow近2千万问答,支持中英文搜索,鼠标放在语句上弹窗显示对应的参考中文或英文, 本站还提供   中文繁体   英文版本   中英对照 版本,有任何建议请联系yoyou2525@163.com。

我想将我的Android Studio应用连接到Firebase,但出现此错误:

无法解决:firebase-auth-15.0.0

这是我当前的屏幕: 当前画面

这里有什么问题吗?

dependencies {
        implementation fileTree(dir: 'libs', include: ['*.jar'])
        implementation 'com.android.support:appcompat-v7:28.0.0'
        implementation 'com.android.support.constraint:constraint-layout:1.1.3'
        testImplementation 'junit:junit:4.12'
        androidTestImplementation 'com.android.support.test:runner:1.0.2'
        androidTestImplementation 'com.android.support.test.espresso:espresso-core:3.0.2'
        implementation 'com.google.firebase:firebase-auth:16.0.1:15.0.0'
    }

我尝试清理项目并再次运行。 它没有改变。

我尝试移除

implementation 'com.google.firebase:firebase-auth:16.0.1:15.0.0'

并将其更改为:

implementation 'com.google.firebase:firebase-auth:16.0.1'
implementation 'com.google.firebase:firebase-auth:16.0.2'
implementation 'com.google.firebase:firebase-auth:16.0.3'

分别使用三个选项,错误消失了,但是Firebase依赖项没有建立。

1 个回复

尝试添加它而不是使用较低版本。

implementation 'com.google.firebase:firebase-auth:16.0.5'

有关更多信息,请按照以下步骤操作: https : //firebase.google.com/support/guides/firebase-android

1 无法解决:firebase-auth-15.0.0。 Firebase中的错误[重复]

这个问题已经在这里有了答案: 将Android Studio项目与Firebase集成以实现Google登录功能时的依赖关系错误 4个答案 我正在尝试将Firebase连接到我的应用程序。 在按下“将Firebase身份验证添加到您的应用程序”后,我收到以下错误消 ...

5 无法解析Firebase身份验证15.0.0

我是Android开发环境的新手,我需要将我的应用程序连接到firebase但是我收到此错误 无法解决:firebase-auth-15.0.0 此错误显示在语句中: 此语句包含两个版本的详细信息,我认为错误是由此引起的,但此特定语句由firebase本身提供。 看图 ...

暂无
暂无

声明:本站的技术帖子网页,遵循CC BY-SA 4.0协议,如果您需要转载,请注明本站网址或者原文地址。任何问题请咨询:yoyou2525@163.com.

 
粤ICP备18138465号  © 2020-2021 STACKOOM.COM