繁体   English   中英

Homebrew-在OSX上设置特定版本的节点

Homebrew - setting a specific version of node on osx

提示:本站收集StackOverFlow近2千万问答,支持中英文搜索,鼠标放在语句上弹窗显示对应的参考中文或英文, 本站还提供   中文繁体   英文版本   中英对照 版本,有任何建议请联系yoyou2525@163.com。

我正在尝试为我的新项目设置节点v 8的要求(因为我想使用react-redux-firebase生成器,它需要v8)。

我在遵循SO和Homebrew上的说明时遇到了麻烦-它们似乎已过时。

我目前正在运行node -v并获得v 10.13.0。

Brew Unlink节点返回

Error: No such keg: /usr/local/Cellar/node

brew搜索节点返回:

酿造搜索节点

==> Formulae
leafnode            node                node@6              nodebrew
libbitcoin-node     node-build          node@8 ✔            nodeenv
llnode              node@10 ✔           node_exporter       nodenv

酿造链接--overwrite --force node @ 8

Linking /usr/local/Cellar/node@8/8.12.0... 
Error: Could not symlink lib/node_modules/npm/.mailmap
/usr/local/lib/node_modules/npm is not writable.

我不能在此命令上使用sudo,因为Homebrew不再支持它。

有谁知道如何让节点v 8运行?

我尝试的所有操作均返回结果,指出当前版本为10

酿造信息节点

node: stable 11.1.0 (bottled), HEAD
Platform built on V8 to build network applications
https://nodejs.org/
Not installed
From: https://github.com/Homebrew/homebrew-core/blob/master/Formula/node.rb
==> Dependencies
Build: pkg-config ✘, python@2 ✘
Recommended: icu4c ✔
Optional: openssl@1.1 ✘
==> Options
--with-openssl@1.1
    Build against Homebrew's OpenSSL instead of the bundled OpenSSL
--without-icu4c
    Build with small-icu (English only) instead of system-icu (all locales)
--without-npm
    npm will not be installed
--HEAD
    Install HEAD version
==> Analytics
install: 343,912 (30 days), 946,087 (90 days), 3,815,131 (365 days)
install_on_request: 254,231 (30 days), 699,371 (90 days), 2,669,901 (365 days)
build_error: 0 (30 days)
问题暂未有回复.您可以查看右边的相关问题.
3 sshuttle 的 Homebrew 特定版本

当我尝试安装旧版本的Sshutle 时, 我正在尝试安装 sshuttle 0.78.5 版并使用以下命令: brew install https://raw.githubusercontent.com/Homebrew/homebrew-core/276d373c333dd386a9220d0f5 ...

4 Homebrew-无法链接node.js

我正在尝试全部安装Node.js,但由于我使用的命令无法正常工作,我有点迷失了 终端显示: 我已经完成了“ brew link --overwrite node”操作,但仍然可以得到相同的结果。 我什至看着一个类似的老问题,也没有用。 ...

5 homebrew - 强制安装,即使SHA1不匹配

我正在通过自制软件安装一些东西,但其中一个依赖项无法安装,说下载的工件具有与自制程序预期不同的SHA1校验和。 罪魁祸首是suite-sparse v4.2.1,并且通过检查自制问题跟踪器,看起来这个软件包的所有者倾向于在没有碰撞版本的情况下进行更改。 我和自制专家签了一张票来仔细检查这 ...

7 Fink和Homebrew-他们可以一起生活在Mac OS X上吗?

我试图使倍频起作用,并发现它需要gnuplot,而gnuplot-nox需要通过Fink安装。 我通常坚持使用Homebrew进行软件包安装。 使用Fink安装某些特定软件包时,以自制软件作为主要软件包管理器是否有任何问题? 他们曾经有冲突吗? 是否会使系统不稳定? ...

10 Homebrew安装特定版本的公式

特别是kubernetes-cli 。 我安装了1.12.0。 我需要1.11.x,但我没有安装。 我已经回顾并尝试了这个帖子中的每个答案,没有任何效果: Homebrew安装特定版本的公式? 我尝试过brew search但没有tapped版本: 我尝试过brew ve ...

2018-10-22 00:35:55 4 6086   homebrew
暂无
暂无

声明:本站的技术帖子网页,遵循CC BY-SA 4.0协议,如果您需要转载,请注明本站网址或者原文地址。任何问题请咨询:yoyou2525@163.com.

 
粤ICP备18138465号  © 2020-2021 STACKOOM.COM