繁体   English   中英

错误:无法解决:com.google.android.gms:play-services-analytics:17.2.0

ERROR: Failed to resolve: com.google.android.gms:play-services-analytics:17.2.0

提示:本站收集StackOverFlow近2千万问答,支持中英文搜索,鼠标放在语句上弹窗显示对应的参考中文或英文, 本站还提供   中文繁体   英文版本   中英对照 版本,有任何建议请联系yoyou2525@163.com。

将Google Play广告更改为最新版本后,出现此错误。

错误:无法解决:com.google.android.gms:play-services-analytics:17.2.0

app.gradle:

apply plugin: 'com.android.application'

android {
    compileSdkVersion 28
    buildToolsVersion '28.0.3'

    defaultConfig {
        applicationId "com.example.app"
        minSdkVersion 15
        targetSdkVersion 26
        versionCode 5
        versionName '1.3.0'
        manifestPlaceholders = [onesignal_app_id: "xyz",
                                // Project number pulled from dashboard, local value is ignored.
                                onesignal_google_project_number: "xyz"]

    }
    buildTypes {
        release {
            minifyEnabled false
            proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro'
        }
    }
    productFlavors {
    }
    aaptOptions {
        cruncherEnabled = false
    }
}

repositories {
    maven { url 'https://maven.google.com' }
}



dependencies {
    implementation fileTree(dir: 'libs', include: ['*.jar'])
    implementation 'com.mcxiaoke.volley:library:1.0.18'
    implementation 'com.github.chrisbanes.photoview:library:1.2.3'

    implementation 'com.google.android.gms:play-services-ads:18.2.0'//11.8.0

    implementation 'com.pkmmte.view:circularimageview:1.1'
    implementation 'com.melnykov:floatingactionbutton:1.3.0'
    implementation 'com.squareup.okhttp:okhttp:2.5.0'
    implementation 'com.github.bumptech.glide:glide:3.7.0'

    implementation 'com.android.support:appcompat-v7:27.1.0'
    implementation 'com.android.support:cardview-v7:27.1.0'
    implementation 'com.android.support:recyclerview-v7:27.1.0'
    implementation 'com.android.support:design:27.1.0'
    implementation 'com.balysv:material-ripple:1.0.2'
    implementation 'com.google.firebase:firebase-messaging:20.0.0'
    implementation 'com.github.hotchemi:android-rate:1.0.1'
    implementation 'com.onesignal:OneSignal:[3.9.1, 3.99.99]'//3.6.2 // 3.8.3
    implementation 'com.google.android.gms:play-services-analytics:17.2.0'
}


apply plugin: 'com.google.gms.google-services'

project.gradle:

buildscript {
    repositories {
        google()
        jcenter()
    }
    dependencies {
        classpath 'com.android.tools.build:gradle:3.2.1'//2.2.3

        classpath 'com.google.gms:google-services:4.0.1'//3.1.1

    }
}

allprojects {
    repositories {
        google()
        jcenter()

    }
}

结果,我该如何解决我的问题? 我无法解决我的问题,我该如何解决? 感谢您的任何回复。

我是游戏开发人员:)

1 个回复

设置多个Google API implementation指令时,它们有时取决于Google SDK中其他库的特定版本。

听起来像问题在于,还有另一个implementation指令,该指令要求与您要升级到的play-services-analytics版本兼容的版本。

为了解决这个问题,我将:

  1. 创建一个不需要任何gradle依赖关系的独立模块..例如,如果没有Java或XML文件。

  2. 复制您要工作的gradle文件

  3. 注释掉所有implementation指令(可能与Google相关的implementation指令就足够了,但不能确定)

  4. 仅取消注释您要更新的1行:

     implementation 'com.google.android.gms:play-services-analytics:17.2.0' 
  5. 然后一次一次取消注释其他implementation指令-每次运行gradle sync以确保项目正确构建。

  6. 当取消注释导致构建再次中断的行时,然后查看该行是否存在导致构建再次失败的更新; 我猜有一个更新,因此将其设置为也使用更新的版本。

1 错误:无法解决:com.google.android.gms:play-services-analytics:18.2.0 [处于保留状态]

同步Gradle时出现此错误。 项目级爬网: 应用程序级Gradle: 我该如何解决我的问题? ---不在乎--- 它给出了这个错误。 “看起来您的帖子主要是代码;请添加更多详细信息。” 无需更多说明! 因此,请关闭此烦人的功能! 无需更多说 ...

8 无法解决:com.google.android.gms:play-services

控制台中显示以下错误消息。 无法解决:com.google.android.gms:play-services:15.0.1安装存储库并同步项目在文件中显示在项目结构对话框中显示 另外,如果我尝试安装存储库,则会遇到以下问题:找不到依赖项“ com.google.android.gms: ...

2018-11-13 07:03:44 2 1880   android
暂无
暂无

声明:本站的技术帖子网页,遵循CC BY-SA 4.0协议,如果您需要转载,请注明本站网址或者原文地址。任何问题请咨询:yoyou2525@163.com.

 
粤ICP备18138465号  © 2020-2022 STACKOOM.COM