繁体   English   中英

找不到 com.google.protobuf.GeneratedMessageV3 的类文件

class file for com.google.protobuf.GeneratedMessageV3 not found

提示:本站收集StackOverFlow近2千万问答,支持中英文搜索,鼠标放在语句上弹窗显示对应的参考中文或英文, 本站还提供   中文繁体   英文版本   中英对照 版本,有任何建议请联系yoyou2525@163.com。

尝试在 Apache Mesos 上调用“make”,在修复了其他一些与 javadocs 相关的问题后,这就是我目前得到的。 有人遇到过同样的问题吗? 这是跟踪:

/Library/Java/JavaVirtualMachines/openjdk-12.0.2.jdk/Contents/Home/bin/javac -h java/jni                \
      -classpath java/target/mesos-1.10.0.jar:/Users/hanshenriksande/Master/mesos/build/src/java/target/protobuf-java-3.5.0.jar                        \
       ../../src/java/src/org/apache/mesos/MesosExecutorDriver.java
Note: ../../src/java/src/org/apache/mesos/MesosExecutorDriver.java uses or overrides a deprecated API.
Note: Recompile with -Xlint:deprecation for details.
An exception has occurred in the compiler (12.0.2). Please file a bug against the Java compiler via the Java bug reporting page (http://bugreport.java.com) after checking the Bug Database (http://bugs.java.com) for duplicates. Include your program and the following diagnostic in your report. Thank you.
com.sun.tools.javac.code.Symbol$CompletionFailure: class file for com.google.protobuf.GeneratedMessageV3 not found
make[1]: *** [java/jni/org_apache_mesos_MesosExecutorDriver.h] Error 4
make: *** [all-recursive] Error 1
1 个回复

Mesos 需要 Java 绑定吗? 如果没有,则运行--disable-java--disable-python查看自动工具选项 如果你需要这个绑定,那么你需要将你的 JVM 降级到 7 或 8。按照这些说明

5 如何修复“找不到引用的类com.google.protobuf”?

我一直在尝试使用Proguard并碰壁。 我运行程序正常,直到它尝试进行SQL连接(在没有proguard的情况下都可以工作),此时它不与(为了可读性而出现错误)连接。 我尝试在没有警告的情况下运行,但我会收到2万多个与com.google.protobuf相关的未解决的引用或分类。 ...

7 找不到com.google.common.collect.BiMap的类文件

我最近更新了Android SDK和Eclipse插件。 之后,我的项目立即引发以下构建错误: 无法解析com.google.common.collect.BiMap类型。 它是从所需的.class文件第1行Java问题间接引用的。 我已经尝试了几种清洁/构建以及对项目构建路径进 ...

暂无
暂无

声明:本站的技术帖子网页,遵循CC BY-SA 4.0协议,如果您需要转载,请注明本站网址或者原文地址。任何问题请咨询:yoyou2525@163.com.

 
粤ICP备18138465号  © 2020-2022 STACKOOM.COM