在安装更新版本的python时出现了一个非常奇怪的情况。

(我之前已经做过很多次了,没有任何问题)

默认情况下,我在Debian GNU / Linux 10(buster)系统上安装了python 3.7.3,并决定将其更新为当前发行版3.7.4。 因此,一如既往,确信自己不会遇到任何问题,所以我手动删除了与python 3.7.3相关的一切。 我浏览了所有包含用于Python 3.7.3的文件的目录以及一些仅属于python3的dirs /文件,因此所有/usr/bin/python3东西... /usr/local/bin/...所有内容libinclude ,全部。

然后,我在目录中预编译了Python 3.7.4( ./configure ... && make -j4 )。

当我进行sudo make install我看到它可以干净地安装并且一切正常。 除了...当我运行python3python3.7我得到了一个python解释器-适用于python 3.7.3:

(我从系统中完全删除的那一个:/)

Python 3.7.3 (default, Apr  3 2019, 05:39:12) 
[GCC 8.3.0] on linux
Type "help", "copyright", "credits" or "license" for more information.
>>>

因此,我运行sudo make altinstall但仍然遇到了3.7.3的解释器!

我意识到我们离Python 3.8的第一个rc版本只有几周了,所以为什么不尝试一下...

我使用sudo make altinstall ./configure ... && make -j4 ,我得到了一个漂亮的闪亮新代码:

Python 3.8.0b4 (default, Sep 17 2019, 12:43:24) 
[GCC 8.3.0] on linux
Type "help", "copyright", "credits" or "license" for more information.
>>> 

那么这里发生了什么? 我只是不明白它如何能重新安装系统上不再存在的python版本?

  ask by Jamie Lindsey translate from so

本文未有回复,本站智能推荐:

4回复

导入模块时出现问题。 Python版本问题?

我在以下方面遇到了一些问题。 我继承了一个我需要使用的 .py 文件,但显然我对作者使用了不同的 python 版本。 我收到这些错误; 任何帮助我指出错误方向的帮助都会很棒。 如果有帮助,我正在使用 Python 3.6.4。
2回复

在Raspberry Pi上安装mitmproxy时python出现问题

我正在尝试在Raspberry Pi上安装mitmproxy,但是遇到了以下问题,我认为这些问题与Python有关。 我已经尝试了无数次尝试和搜索,但都没有运气。 不知道这是否是由于mitmproxy需要的库的依赖关系,或者我构建了很多次的python安装。 我也曾尝试使用Wifi
2回复

使用 python 3.6 安装 pyinstaller 时出现问题

我无法使用 python 安装 pyinstaller,每次尝试时都会出现以下错误:
1回复

使用python3安装opencv3时出现问题

我正在尝试在osx 10.11上使用python3安装opencv3,但是出现问题。 我同时安装了python2和python3,所以我编辑了etc/paths使其具有以下顺序的路径: ...我收到以下错误: 根据错误显示,它的确使用了正确的python版本。 我看不到任何环
2回复

在Windows中安装Python时出现问题[重复]

这个问题已经在这里有了答案: 在Python中“ SyntaxError:调用'print'时缺少括号”是什么意思? 7个答案 我在Windows 7上安装了Python 3.4。对环境变量进行了更改。 这是我的用户变量: 变量:PATH值:C:\\
2回复

尝试在python3上安装Selenium时出现问题

这个问题已经在这里有了答案: pip安装失败,出现以下错误:OSError:[Errno 13]目录 7 上的权限被拒绝 我正在尝试在python 3.6上安装selenium。 带命令 点安装硒 我收到此错误: 使用已缓存的htt
1回复

使用Anaconda安装Python3.6时出现问题

我是Linux的新手,并尝试使用Anaconda安装Python 3.6 ,请按照此处的说明进行操作。 当我运行conda install python==3.6 ,得到以下信息: 如何解决此错误? 我已经有了Python 3.5,并且想升级到3.6。
4回复

使用 PIP 安装时出现问题

我在使用 pip install 导入时遇到问题。 我得到的错误如下: 我对编程很陌生,所以我只是在 windows 命令提示符下尝试了这个,它说“pip 不被识别为内部或外部命令、可运行的程序或批处理文件”。 如果有帮助,我正在使用 Spyder,但我不确定我在这里遗漏了什么。 谢谢你的帮助