繁体   English   中英

Javers 5.6.3 需要 Java 9?

Java 9 required for Javers 5.6.3?

提示:本站收集StackOverFlow近2千万问答,支持中英文搜索,鼠标放在语句上弹窗显示对应的参考中文或英文, 本站还提供   中文繁体   英文版本   中英对照 版本,有任何建议请联系yoyou2525@163.com。

在 pom.xml 中包含 javers 5.6.3 后,我收到以下部署错误。 我正在使用 java 8 和 Wildfly 10。根据 Javers 的文档,在我看来 Java 8 与 javers 5.6.3 兼容,因此我很困惑。 聚甲醛:

<dependency>
    <groupId>org.javers</groupId>
    <artifactId>javers-core</artifactId>
    <version>5.6.3</version>
</dependency>

服务器错误:

[org.jboss.as.server.deployment](MSC 服务线程 1-3)WFLYSRV0003:无法在 /content/myproject.war/WEB-INF/ 索引类 META-INF/versions/9/module-info.class lib/classgraph-4.8.43.jar: java.lang.IllegalStateException: 未知标签! pos=3 poolCount = 18 at org.jboss.jandex.Indexer.processConstantPool(Indexer.java:1416) at org.jboss.jandex.Indexer.index(Indexer.java:1450) at org.jboss.as.server.deployment .annotation.ResourceRootIndexer.indexResourceRoot(ResourceRootIndexer.java:99) 在 org.jboss.as.server.deployment.annotation.AnnotationIndexProcessor.deploy(AnnotationIndexProcessor.java:51) 在 org.jboss.as.server.deployment.DeploymentUnitPhaseService.start (DeploymentUnitPhaseService.java:147) at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1948) at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1881) at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149) at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624) at java.lang.Thread.run(Thread.java:748)

发布了类似的问题,但Classgraph 对 Javers 的依赖没有答案需要 JDK9+

问题暂未有回复.您可以查看右边的相关问题.
2 Java 9反应流。 为什么需要处理器?

我一直在Java中看到反应流概念,它倾向于标准化javaRX和Spring反应概念。 一切都很好,除了为了对流进行一些转换,你需要实现一个或多个处理器。 我的问题是需要处理器接口处理器,它扩展了Subscriber,Publisher 看起来你通过了一个有趣的地方进行转换,你将它与生产者 ...

3 接口中需要私有静态方法 - Java 9 [重复]

这个问题在这里已有答案: 私有接口方法支持 3个答案 Java 9有两个新增的接口 私人方法 私有静态方法 现在,我需要接口中的 私有方法 。 您希望在界面内使用该方法,但不允许从界面外部访问它。 我也理解在Java 类中使用私有静 ...

4 Java 9:不需要通过反射访问“打开”模块?

Java 模块逻辑中的opens关键字允许反射访问( 此处)。 我最近移植了一个复杂的 JavaFX 应用程序。 到 Java 15 成功,但这是一场噩梦,因为 JavaFX 正确地基于反射访问。 我的问题是关于一个更简单的Java应用程序15,完美的作品,但我预期运行时错误没有发生! 为什么? ...

5 VSTS buildagent:Java 9

我在构建服务器上安装了最新的Java sdk(包括jre)版本9.0.1,然后重新启动了代理。 代理似乎无法检测到Java,缺少Java功能,并且由于未在代理上设置Java能力,因此无法运行构建。 我需要做些什么才能使Java得到认可? 最后一个Java 8. *版本被正确识别 ...

6 将Javax嵌入Java 9

我试图解决这个问题几个小时,我需要帮助: 它不是未知的问题,javax不是java 9的一部分,我无法弄清楚如何在没有以下exeption的情况下运行它: 这是我的例子: 这是我的pom.xml: 这是我的hibernate.cfg.xml 我补充道 ...

7 sonarqube分析java 9

docker sonarqube最新版本6.7.1在java 9上打破了我的maven构建: java 8上的相同配置工作完美。 怎么解决? ...

8 Java9中的KeyTab

在JDK8中,可以这样制作一个keytab文件: 在JDK9中,这产生了 有 但它似乎缺少ktab和密码功能。 在Java9中制作密钥表文件的最佳方法是什么? 使用JDK8中的1.5M sun.security.jar可以工作,但并不理想。 从Proce ...

9 Java 9 接口与类

由于 Java 9 将允许我们在接口中也定义private和private static方法,那么interface和class的剩余区别是什么? 而且,Java 是不是在慢慢地走向多重继承? ...

10 之间的区别是需要公共VS需要Java 9中的可传递

我了解到,为了使用任何其他出口模块,我们需要指定模块的requires : 当othermodule使用上thirdmodule和mymodule需要,作为好, othermodule应该这样定义传递依赖: 但是,我已经看到许多网站在这种情况下使用public关键字: 两 ...

暂无
暂无

声明:本站的技术帖子网页,遵循CC BY-SA 4.0协议,如果您需要转载,请注明本站网址或者原文地址。任何问题请咨询:yoyou2525@163.com.

 
粤ICP备18138465号  © 2020-2022 STACKOOM.COM