对不起,如果这是一个愚蠢的问题,但我是新手,不知道如何解决这个问题,我以前有 Python 2.7,但由于它不再有效,我现在安装了 python 3,我该如何为 Anaconda 更改它? 因为我是用以前的版本安装的

#1楼 票数:0

首先,通过运行确保您拥有最新版本的 conda

conda update conda

然后运行

conda install python=3.8

  ask by Sara Djaroud translate from so

未解决问题?本站智能推荐:

1回复

即使安装了 anaconda 和 notebook,也无法识别 Jupyter notebook

我在 Ubuntu 18.04 中安装了 anaconda,然后我使用以下命令安装了 Jupyter notebook: 并且笔记本打开时使用命令 Jupiter notebook ,但是,然后我安装了一些软件包,如 python3.8-dev 和 gcc ,安装它们后,命令 Jupiter n
2回复

从 Anaconda 启动 Jupyter Notebook 时出现问题

我在启动 Jupyter Notebook 时遇到问题。 我尝试了两种方法,但似乎出错了。 1 - 使用命令jupyter notebook从 Anaconda Prompt 启动或直接从 Anaconda 菜单中选择 我得到以下信息: 2 - 使用相同的命令从命令行启动 我得到以下信息:
1回复

Jupyter笔记本不承认“进口火炬”

要按照官方网站的指示在Ubuntu上安装PyTorch ,我做了pip3 install torch torchvision ,我可以使用python3.5命令运行PyTorch 。 但是,当我运行Jupyter Notebook (我只是在终端中运行Jupyter Notebook并使用
1回复

Scikit-learn 软件包升级后 Jupyter 无法运行:模块“asyncio”没有属性“WindowsSelectorEventLoopPolicy”

我在 Keras 包装器和 VotingClassifier 方面遇到了一些问题,所以我尝试通过 Conda 升级 sci-kit learn。 但是现在当我尝试从导航器或快捷方式启动它时,它会启动提示一小会然后关闭。 Anaconda 咳这个错误: Traceback (most recent
1回复

Anaconda 3为什么会给出OSError:[WinError 193]%1不是有效的Win32应用程序?

当我在jupyter笔记本上尝试“导入numpy”时,出现以下错误:OSError:[WinError 193]%1不是有效的Win32应用程序。 它曾经可以正常工作,但是前几天我在cmd上运行了“ pip install numpy”,这样我就可以在我的PyCharm项目(不在anaco
1回复

在 python3 上的 Jupiter 笔记本上导入 Seaborn 时出错

也许这是一个简单的问题。 当我运行import seaborn as sns它返回一个错误 没有名为“seaborn”的模块 相反,如果运行: 我没有错误。 为什么 ? 因为我有 python 2.7 和 3,我在 python3 上使用 Jupyter notebook。 我使用了pip
2回复

ModuleNotFoundError:没有名为“extruct”的模块(Python 3.7 Jupyter Notebook)

我用 pip 安装了“提取包”: Collecting extruct Downloading https://files.pythonhosted.org/packages/d4/ab/9b705a8b2cf0bca59ec1b0729c8b8f80ecc8c79aced20463c1e19f
1回复

与anaconda和python库相关的问题

每次我在 jupyter 中导入任何库时都会显示这种类型的错误,我使用的是 64 位窗口操作系统。