我在尝试在 VScode 中选择 python 解释器时遇到了一些麻烦。 正如你在这张图片中看到的( VScode: select python interpreter ),VScode 要求我选择一个 python 解释器,但是当我点击它时,它没有给我任何选项: python interpreter

除了这个问题(我相信它们是相关的),我无法调试,因为我收到以下错误消息:无法调试

有没有人遇到过这个问题? 谢谢!

  ask by Luís Amaral translate from so

本文未有回复,本站智能推荐:

2回复

Python('base':conda)与opt/local/bin中的一个相比,有什么区别?

我正在使用Visual Studio Code,并尝试设置我的python解释器,然后遇到了这个问题。 “ opt / local / bin / python xx”中的一个,和“ / opt / miniconda3 / bin / python”中的一个,它们有何不同? 先感谢您。 它们基本
1回复

python如何在内部工作?是不是一个python的解释器可以使CPU使用率太高?

脚本 我在php中使用exec(...)调用python脚本,python工作它的部分,它是非结构化的环境,没有django或任何其他框架。 产品是基于客户端的产品,大多数任务都是长期运行的任务。 因此,如果客户有任何要求,必须立即满足。 对我们来说,时间也是我们不能耽误过程
4回复

如何让VisualStudioCode使用不同的Python解释器?

我是 VS Code/Python 的新手,我正在尝试让 VSCode 运行特定版本的 Python(似乎我安装了多个版本)。 我尝试了以下代码: 当我运行文件时,出于某种原因,它显示: 我尝试了以下操作:在 VSCode 的最底部,我单击 Python 版本,然后单击“Python 3.7.3 6
2回复

使用带有局部变量的python代码运行python解释器

很多时候,我们在某些用户定义函数中遇到错误,并希望对其进行调试。 如果错误是在主程序中发生的,我们可以使用-i标志在错误之后保留变量。 但是,如果错误发生在用户定义的函数中,则无法访问函数的局部变量。 有没有一种方法可以让我们通过python代码打开python解释器,接受来自stdin代
1回复

找不到Python解释器VSCode

所以自从我不小心删除了 python 后,我就遇到了一个问题,当我重新安装它时,VSCode 一直给我一个问题,说“你需要在开始调试之前选择一个 Python 解释器。提示:点击状态栏中的“选择 Python 解释器” .” 当我去酒吧时,没有可用的口译员。 当我尝试使用我兄弟的笔记本电脑时,它会显
3回复

vscode找不到我的自定义python包

我是 VS Code 在 Windows 上进行 python 开发的新手,我的 pylint 找不到包。 这是我的项目目录结构。 我编写了 mytest.py 脚本代码,如: 我使用 C:/Anaconda3/python.exe 作为 python 解释器当我单击 VS Code 右上角的▷(在
1回复

在VSCode中为项目设置python解释器

这个问题已经存在的可能性很高,但到目前为止我可以找到任何有用的答案:/问题是我为一个新的小型 python 项目创建了一个新的 github 存储库。 我想在 VS-Code 中工作并使用 miniconda 创建一个环境。 这一切都没有问题。 但是有什么方法可以确保,当我打开 VSCode 时,它
2回复

在VisualStudioCode中使用Python3.6

我正在尝试将Pool.starmap()函数用于多处理,但仅在Python 3.3+中可用。 我的Python默认版本是2.7.10,但是我还安装了Python 3.6。 我试过在命令面板中更改所选的Python解释器,甚至说它当前使用3.6解释器,它输出以下内容: 我尝试重新启动VS