我目前正在开发一个使用(以及其他)nd4j、deeplearning4j 依赖项的项目。 这些依赖包括不同操作系统的版本,如“nd4j-native-1.0.0-beta6-android-arm.jar”或“nd4j-native-1.0.0-beta6-linux-armhf.jar”等。

由于该项目只能在 linux-x64 上运行,我想知道是否有办法告诉 Maven复制不需要的 JAR。 我希望减少不必要的库所需的所需磁盘空间。

pom.xml 目前看起来像这样能够生成可部署的输出:

<project xmlns="http://maven.apache.org/POM/4.0.0"
         xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
         xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
    <modelVersion>4.0.0</modelVersion>

    <groupId>MyGroup</groupId>
    <artifactId>MyApp</artifactId>
    <version>1.0-SNAPSHOT</version>
    <properties>
        <maven.compiler.source>1.8</maven.compiler.source>
        <maven.compiler.target>1.8</maven.compiler.target>
    </properties>
    <dependencies>
        <dependency>
            <groupId>org.eclipse.paho</groupId>
            <artifactId>org.eclipse.paho.client.mqttv3</artifactId>
            <version>1.2.2</version>
        </dependency>
        <dependency>
            <groupId>org.apache.clerezza.ext</groupId>
            <artifactId>org.json.simple</artifactId>
            <version>0.4</version>
        </dependency>
        <dependency>
            <groupId>com.kohlschutter.junixsocket</groupId>
            <artifactId>junixsocket-core</artifactId>
            <version>2.3.1</version>
        </dependency>
        <dependency>
            <groupId>com.kohlschutter.junixsocket</groupId>
            <artifactId>junixsocket-server</artifactId>
            <version>2.3.1</version>
        </dependency>
        <dependency>
            <groupId>org.nd4j</groupId>
            <artifactId>nd4j-native-platform</artifactId>
            <version>1.0.0-beta6</version>
        </dependency>
        <dependency>
            <groupId>org.deeplearning4j</groupId>
            <artifactId>deeplearning4j-core</artifactId>
            <version>1.0.0-beta6</version>
        </dependency>
        <dependency>
            <groupId>org.deeplearning4j</groupId>
            <artifactId>deeplearning4j-parallel-wrapper</artifactId>
            <version>1.0.0-beta6</version>
        </dependency>
    </dependencies>

    <packaging>jar</packaging>
    <build>
        <plugins>
            <plugin>
                <groupId>org.apache.maven.plugins</groupId>
                <artifactId>maven-dependency-plugin</artifactId>
                <executions>
                    <execution>
                        <id>copy-dependencies</id>
                        <phase>prepare-package</phase>
                        <goals>
                            <goal>copy-dependencies</goal>
                        </goals>
                        <configuration>
                            <outputDirectory>${project.build.directory}/libs</outputDirectory>
                            <useRepositoryLayout>true</useRepositoryLayout>
                        </configuration>
                    </execution>
                </executions>
            </plugin>
            <plugin>
                <groupId>org.apache.maven.plugins</groupId>
                <artifactId>maven-jar-plugin</artifactId>
                <configuration>
                    <archive>
                        <manifest>
                            <addClasspath>true</addClasspath>
                            <classpathLayoutType>repository</classpathLayoutType>
                            <classpathPrefix>libs/</classpathPrefix>
                            <mainClass>MyMainClass</mainClass>
                        </manifest>
                    </archive>
                </configuration>
            </plugin>
        </plugins>
    </build>

</project>

#1楼 票数:2

通常,如果您想为 dl4j 或基于 javacpp 的任何东西捆绑特定于平台的二进制文件,您可以执行以下操作: https : //github.com/bytedeco/javacpp-presets/wiki/Reducing-the-Number-of-Dependencies

具体来说,您只需为所有 javacpp 依赖项指定 -Djavacpp.platform=linux-x86_64 即可。

#2楼 票数:0

您可以在依赖项上设置<exclusions>

https://maven.apache.org/guides/introduction/introduction-to-optional-and-excludes-dependencies.html

一个例子是:

   <dependency>
      <groupId>com.something</groupId>
      <artifactId>some-jar</artifactId>
      <version>1.0.0</version>
      <scope>compile</scope>
      <exclusions>
        <exclusion>  
          <groupId>de.dumm</groupId>
          <artifactId>nicht-benutzen</artifactId>
        </exclusion>
      </exclusions> 
    </dependency>

  ask by Max Senft translate from so

未解决问题?本站智能推荐:

1回复

Maven依赖插件:仅复制测试依赖项

我已经使用Maven Dependency插件将项目的所有运行时依赖项组装到一个输出目录中。 现在,我想将所有其他测试依赖项组合到一个单独的目录中。 但是,当我包括范围test并排除compile范围或runtime范围时,它仍然始终也复制所有编译依赖项。 有没有办法只复制其他测试依赖
3回复

筛选由Maven的复制依赖项复制的依赖项?

我需要基本上完成以下任务: 将我的库构建为JAR。 (很简单,已经完成了。) 将我的库的依赖项复制到本地文件夹,包括主项目JAR,不包括标记为provided依赖项。 我似乎无法完成第二部分。 有没有更好的方法来做到这一点,而不是我在下面这样做? 我实际上是将这些JAR部署
1回复

具有完整jar名称的Maven复制依赖项[重复]

这个问题在这里已经有了答案: 在 maven 中自定义依赖文件名(1 个回答) 10 个月前关闭。 我想将 maven 依赖项复制到 ${project.
1回复

Maven依赖项:复制带有基本版本的工件

我正在尝试通过命令行使用Maven下载一些工件。 我只知道工件的基本版本,但是它们在nexus存储库中有单独的时间戳。 例如: 工件com.mycompany.subject:any-artifact:3.0.0-SNAPSHOT:war:plugins具有以下坐标com.mycomp
1回复

Maven复制依赖项包括GroupIds和所有的传递元素

我试图弄清楚如何将所有依赖项复制到显式版本以及所有必需的依赖项。 例如:我的项目需要第三方库的版本3 ,称为foobar 。 我想将版本3库复制到名为lib-foobar-${foobar.version}的文件夹中。 在此文件夹中,有那些需要使用版本3中的foobar的jar。这意味
1回复

Maven:如何按特定顺序解压缩依赖项?

我的项目取决于许多ZIP资源。 使用“maven-dependency-plugin”及其“unpack-dependencies”,我知道如何解压每个依赖项。 但是(由于不同的原因,我在这里无法解释),我必须以特定的顺序(*)解包依赖项。 是否可以按特定顺序解压缩,还是可以管理依赖
1回复

将所有Maven依赖项从子pom复制到目录

我正在尝试将项目及其子模块的所有依赖项复制到特定文件夹中(让我们说出parent / target / lib) 该项目是这样的: 以我的理解,这样做的唯一方法是在每个子模块中使用maven复制依赖关系,如下所示: 我对此有多个问题: lib文件夹将包含工件的所有版本(我只想要
2回复

如何使用maven依赖插件将类型为pom的依赖项复制到某个位置

需要解析以下依赖项并将子依赖项复制到特定位置。 但是当我使用 maven 依赖插件进行复制时,只会复制 pom 文件,而不是那些 pom.xml 中定义的依赖项。 我的插件如下, 任何线索?