您好,我正在尝试安装 mathics python3 setup.py install --user 但我收到此错误:未找到“python-dateutil”发行版,并且是 Mathics 所必需的

当我尝试安装 date util 时,我得到了这个

root@thodo-Inspiron-15-3567:/home/thodo/Documents/Mathics-master# pip install python-dateutil
WARNING: pip is being invoked by an old script wrapper. This will fail in a future version of pip.
Please see https://github.com/pypa/pip/issues/5599 for advice on fixing the underlying issue.
To avoid this problem you can invoke Python with '-m pip' instead of running pip directly.
DEPRECATION: Python 2.7 reached the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 is no longer maintained. A future version of pip will drop support for Python 2.7. More details about Python 2 support in pip, can be found at https://pip.pypa.io/en/latest/development/release-process/#python-2-support
Requirement already satisfied: python-dateutil in /usr/local/lib/python2.7/dist-packages (1.4)

有人可以帮忙安装数学,谢谢

#1楼 票数:0

您的输出中有许多对 python 2.7 的引用,因此您的pip正在安装到python 2.7

要安装到python3 ,只需使用

python3 -m pip install python-dateutil

  ask by Thodosss translate from so

未解决问题?本站智能推荐:

1回复

错误:找不到“python-dateutil”分发版,数学需要它

您好,我正在尝试安装 mathics python3 setup.py install --user 但我收到此错误:未找到“python-dateutil”发行版,并且是 Mathics 所必需的 当我尝试安装 date util 时,我得到了这个 有人可以帮忙安装数学,谢谢
2回复

无法安装python-dateutil

我试图在堆栈上搜索相同的问题,但没有一个是有用的和精确的。 我尝试安装python-dateutil。 我以一种方式,然后以另一种方式: 1)我从https://pypi.python.org/pypi/python-dateutil/下载了python-dateutil-2.4.2.
10回复

未找到“pip==7.1.0”分发版,应用程序需要此分发版

我的 ubuntu 16 上有最新版本的 pip 8.1.1。但我无法通过 pip 安装任何模块,因为我一直收到此错误。 我找到了一个类似的链接,但没有帮助。
1回复

pkg_resources.DistributionNotFound:未找到“pip==19.0.3”分发版,应用程序需要此分发版

我跑步的时候得到这个 我需要它来运行 py2exe,因此我们不胜感激。
1回复

pip安装python-dateutil不起作用

命令: 给出此错误: 但是easy_install python-dateutil可以正常工作。
1回复

升级Python包dateutil:找不到版本

我尝试使用pip install dateutil --upgrade将dateutil从2.5.3升级到最新版本2.6.0 ,但是遇到了问题Could not find a version 。 我检查了帖子找不到满足要求的版本 。 跑pip freeze | grep dateuti
2回复

java版的python-dateutil

Python有一个非常方便的包,它可以解析几乎任何明确的日期,并在解析失败时提供有用的错误消息python-dateutil 。 与SimpleDateFormat类的比较是不利的 - AFAICT SimpleDateFormat只能处理一种确切的日期格式,并且错误消息没有粒度。 我查
1回复

在python中安装CsvFormat时:“找不到CsvFormat的匹配分发”错误

我正在尝试安装CsvFormat软件包 我正在使用python 2.7.10 错误是
1回复

尽管已安装celery,但找不到python-dateutil

我激活了virtualenv并且正在运行命令 投 但是python-dateutil已安装在我的virtualenv中。 我该如何解决?
1回复

错误:找不到 ipython==7.17.0 的匹配发行版

我向 Heroku 上传了一个 Python 应用程序。 在我的requirements.txt文件中,我有一行ipython==7.17.0但 Heroku 似乎无法检索它,我不明白为什么会发生这种情况,因为我可以在我的机器上下载该ipython版本。 抛出的完整错误是: