我正在尝试在我的 Windows 机器上安装 Confluent Platform。 据我所知,安装 Confluent Platform 将使我能够访问 Apache Kafka 包中没有的 KSQL。 另一个障碍是:KSQL 不能直接在 windows 上运行,它需要 Unix 环境。 因为我在 Windows 上,所以我的选择是有限的。 我探索了以下选项:

  1. 我尝试使用适用于 Linux 的 Windows 子系统,但从 Windows App Store 安装任何东西在我的环境中都受到限制。 因此,无法从应用商店安装 Ubuntu。

  2. 因为我的系统上安装了 docker。 我计划拉取 Ubuntu 映像并在其中运行 Kafka。 我从 Docker hub 拉取了 Ubuntu 镜像。 现在,我需要下载 confluent-platform。 我打算使用 WGET 下载它,但不确定需要提供给 wget 的 URL 或路径。

请建议我下载融合包的路径。

#1楼 票数:1

您可以使用而不是裸露的 ubuntu 图像。

它运行一个 Debian 基础,所以如果你想扩展它,apt-get 仍然可以工作

#2楼 票数:0 已采纳

请建议我下载融合包的路径

试试 Confluent 网站??

据我所知,安装 Confluent Platform 将使我能够访问 Apache Kafka 包中没有的 KSQL。

首先,它现在被称为 ksqlDB。 其次,它适用于任何 Kafka 提供者。 Confluent 提供 Apache Kafka 作为其发行版的一部分

您可以将 ksqlDB 容器与在 Windows 上运行的 Apache Kafka 一起使用

或者您可以在容器中运行所有内容,如快速入门所示 - https://ksqldb.io/quickstart.html

  ask by Praveenks translate from so

未解决问题?本站智能推荐:

2回复

在 Docker 上访问 KSQL CLI 的问题

我第一次尝试在 Windows 终端上访问 KSQL CLI,但出现错误: Unable to find image 'cp-ksql-cli:5.3.1' locally 为此,我获得了 docker 图像 所以: 还有它: 并得到错误: 我是 KSQL 的新手,我不知道这是否是
1回复

如何运行 confluent-5.3.2-2.12 平台?

环境: CentOS7 openjdk 版本“1.8.0_181” 我下载了confluent-5.3.2-2.12.tar.gz并解压到/opt/confluent 。 我正在关注“安装和运行 KSQL | 通过 Confluent 升级您的 KSQL ”( https://youtu.b
1回复

Windows 上的 Confluent KSQL 服务器 - 无法找到或加载主类

我想连接到我自己的 Kafka 实例以尝试 KSQL。 我下载了最新版本的 Confluent 开源平台 - https://www.confluent.io/download/ 我按照https://docs.confluent.io/current/ksql/docs/installation
1回复

在没有 Confluent Platform 的情况下使用 Apache Kafka 时,Avro 格式可以用于 KSQL 吗?

我在文档中看到 KSQL 通过 Confluent Schema 注册表支持 Avro 格式。 但是如果使用 Apache Kafka(不是 Confluent Platform)怎么办? 是否可以选择在不使用架构注册表的情况下使用 Avro SpecificRecord 架构?
1回复

融合 KSQL 中的空处理

您能否让我知道如何处理 KSQL 中的 Null 值。 我试图处理 4 种可能的方法,但没有得到解决。 尝试了 4 种在 KSQL 中用不同的值替换 NULL 的方法,但出现了问题。
1回复

编译 Confluent KsqlDB 时的类型转换问题

我正在尝试编译( mvn pacakge pacakge with java 11.0.2)KSQL v5.3.1。 我在编译ksql-common遇到以下错误: 非常感谢帮助; 谢谢!
1回复

自定义 UDAF 不起作用(Ksql:Confluent)

我在 Ksql 中创建自定义 UDAF 时遇到问题。 用例是在滚动窗口中查找列的“第一个”和“最后一个”值。 没有这样的内置 UDAF ( https://docs.confluent.io/current/ksql/docs/syntax-reference.html#aggregate-func
1回复

升级到 Confluent 4.1 后,Schema Registry 无法启动

我最近将 Confluent 升级到 4.1,但模式注册表似乎有一些问题。 在confluent start模式注册表(以及因此 ksql-server)无法启动。 这是我在 schema-registry 的日志中得到的错误: 我不知道为什么会报告此错误,并且错误消息对我来说意义不大。 失