繁体   English   中英

我无法在 anaconda 中创建 python 3.8 环境

I can't create a python 3.8 environment in anaconda

提示:本站收集StackOverFlow近2千万问答,支持中英文搜索,鼠标放在语句上弹窗显示对应的参考中文或英文, 本站还提供   中文繁体   英文版本   中英对照 版本,有任何建议请联系yoyou2525@163.com。

我是社区的新手,所以感谢您给我的任何支持。 我的问题:

我试图为 python 3.8 创建一个新的 anaconda 环境

(base) C:\Users\user>conda create -n My_Env_py38 python=3.8 anaconda

在它尝试解决环境失败后,我收到以下消息:

UnsatisfiableError: The following specifications were found to be incompatible with each other:

Output in format: Requested package -> Available versions

Package python conflicts for:
python=3.8
anaconda -> anaconda-project==0.8.3=py_0 -> python[version='2.7.*|3.5.*|3.6.*|>=3.5|>=3.6|>=3.8,<3.9.0a0|3.7.*']
anaconda -> python[version='2.7.13|2.7.14|2.7.14|2.7.15|2.7.15|2.7.16|3.6.9|3.7.4|3.6.8|3.7.3|3.7.3|3.6.7|3.7.1|3.7.0|3.6.6|3.6.5|3.5.5|3.6.4|3.5.4|3.6.3|3.5.4|3.6.2|3.5.4|>=2.7,<2.8.0a0|>=3.7,<3.8.0a0|>=3.6,<3.7.0a0|>=3.5,<3.6.0a0',build='h6679aeb_11|hb034564_12|h59f5a59_20|hdec4e59_20|h9e2ca53_1|h8c3f1cb_23|h0c2934d_2|hea74fb7_0|hea74fb7_0|he216670_0|hcb6e200_5|h8c8aaf0_6|h8c8aaf0_0|h9f7ef89_7|h5263a28_0|h5500b2f_0|hcb6e200_0|h8c8aaf0_1|h9f7ef89_2|h0c2934d_0|h6538335_1|h1357f44_23|hd3c4935_11']

我已经更新了蟒蛇。 (并且在更新前后使用python 3.7.6一直运行良好)我也尝试在当前环境中安装python 3.8,anaconda也无法解决该环境。 有任何想法吗?

谢谢

1 个回复

我终于从 Anaconda 导航器创建了一个新环境; 我没有指定python版本,所以它用python 3.7.6创建了它。 然后(再次从导航器)我更新了 python 版本(到 3.8.1); 它似乎工作正常。 出于某种原因,当我尝试更新现有环境或从命令提示符创建新环境时,它没有工作过; 不确定现在是否可能,但这种替代方法有效。

1 无法使用python = 3.4创建Anaconda环境

我正在尝试使用Python = 3.4设置Anaconda环境。 我已经包含了conda-forge频道,但仍然收到此错误: 当我尝试使用: 我得到: 我对Anaconda和Python相当陌生,不知道要搜索什么。 这篇文章: 为什么conda无法在安装了p ...

2 我无法创建 Anaconda 环境

我正在尝试使用 conda conda create -n snakeAI python=3.5创建一个 Anaconda 环境,它显示 但是当我使用conda info --envs来显示我的所有环境时,它不会显示snakeAI ...

3 无法将 Anaconda 基础升级到 Python 3.8

我想将我的基础环境升级到 Python 3.8。 根据官方文档,我应该只运行conda install -c anaconda python 。 然而,这只会升级 Python 3.7,所以,最后: conda update -c anaconda python只更新了一些包,而不是 Pyth ...

4 无法创建anaconda环境

我正在使用 conda 创建一个虚拟环境。 我下载了这个存储库中的文件并尝试创建环境,但每次出现此错误 https://github.com/Pierian-Data/Plotly-Dashboards-with-Dash ...

6 如何使用 Anaconda 升级到 Python 3.8?

我最近在我的电脑上安装了 Python 3.8。 我现在有 Python 3.7 和 3.8。 我想删除 3.7 但我不想搞砸任何事情。 当我在 Anaconda Prompt 中输入“python --version”时, 蟒蛇 3.7.9 我担心如果我卸载 3.7,Anaconda ...

9 创建与现有python环境相同的anaconda环境

我有一个安装了非常特定的软件包的python 3.4环境。 是否有一种简单的方法来创建anaconda环境,而不会创建python环境,而是将所有相同的软件包安装在一起,然后手动安装这些软件包。 例如。 我想这样做,因为我想共享一个python脚本并使其他人尽可能容易地运行它。 ...

暂无
暂无

声明:本站的技术帖子网页,遵循CC BY-SA 4.0协议,如果您需要转载,请注明本站网址或者原文地址。任何问题请咨询:yoyou2525@163.com.

 
粤ICP备18138465号  © 2020-2022 STACKOOM.COM