繁体   English   中英

从 NPM Gulp 安装

Installing from NPM Gulp

提示:本站收集StackOverFlow近2千万问答,支持中英文搜索,鼠标放在语句上弹窗显示对应的参考中文或英文, 本站还提供   中文繁体   英文版本   中英对照 版本,有任何建议请联系yoyou2525@163.com。

在我的任务 gulp 上,我尝试使用 npm 包的安装并按照说明使用它们。 我是用 swiper 做的

npm install swiper 

之后,我尝试根据其中一个条件进行连接。

  // core version + navigation, pagination modules:
     import Swiper, { Navigation, Pagination } from 'swiper';

  // configure Swiper to use modules
     Swiper.use([Navigation, Pagination]);

  // import Swiper bundle with all modules installed
     import Swiper from 'swiper/bundle'; 

在此处输入图片说明

1 个回复

UPD:gulp-browserify 这已经解决了。

1 使用 npm 安装 gulp

我正在尝试使用以下命令(使用和不使用 sudo)在 DigitalOcean droplet 上通过 npm 安装 gulp: 我遇到了我无法弄清楚的错误: 节点安装是根据本指南进行的。 ...

3 NPM安装Gulp / Elixir

我正在在线上课程,并下载了Node和NPM。 我已经完成了package.json文件,并且在安装过程中遇到了一些问题。 我真的不明白错误消息。 我拥有最新版本的Node,我试图将其降级到6.10.3(在线课程中为同一版本),但是我仍然无法正常工作。 这里有人知道问题可能是什 ...

4 在Windows上安装Gulp(Npm问题)

我正在尝试为我的Angular UI项目安装Gulp,但由于它的依赖性而无法安装,对此我感到有些惊讶。 因此,节点安装正常,但是npm.js由于文件路径太长错误而拒绝安装。 我的文件夹结构是75个字符长,其中260个可用字符中,剩下185个字符供npm使用。 我在这里丢失了什么吗,还是np ...

2017-05-01 21:48:36 1 381   npm/ gulp
5 使用npm安装gulp插件

我对使用npm和gulp感到困惑。 我知道gulp只是一个任务运行器,用于自动化工作流,而npm基本上是node.js包管理器。 但是,要安装gulp插件,我们运行npm install --save-dev gulp-uglify ,为什么? 我们使用相同的cli命令安装npm模 ...

6 gulp未知的npm安装语法

我一直在大口大口地清理目录的 “食谱”。 他们建议使用vanilla node del模块并运行npm i gulp del 。 该安装语法是什么? 我看过npm install docs并认为它可能是有作用域的软件包 ,但是它并没有完全遵循语法,并且该模块似乎没有安装在适当的位置。 ...

7 无法通过npm安装和运行gulp

我试图通过NPM安装吞掉 ,这样我可以运行我的项目。 据我所知,我需要做的就是从项目位置的命令行运行“npm install gulp” ,如下所示: 但它似乎不起作用,因为如果我从命令行运行“gulp”没有任何反应。 在我的package.json文件中,我有这些 ...

8 NPM自动安装gulp组件

我正在设置gulp,以对旧版.NET WebForms项目中的JS文件执行任务。 我已经安装了NPM,然后将其用于安装Gulp,并且我可以成功运行执行gulpfile.js的gulp。 现在,我有了可以使用npm安装的依赖项,例如gulp-concat,gulp-uglify等。我不希望每个 ...

2015-08-18 17:34:07 1 129   npm/ gulp
9 如何使用 NPM 和 Gulp 安装 Slick Carousel?

除了npm 网站上的npm npm install slick-carousel之外,我找不到任何关于此的文档。 我没有太多以这种方式安装插件的经验,所以如果有人能帮我一把,那就太好了。 这是我到目前为止收集的内容: 我通过 npm 安装 jquery,以便 slick-carousel 可 ...

10 在 docker4drupal 中安装 npm 和 gulp

我正在开发一个由Droopler发行版和docker4drupal构建的现有项目。 根据Droopler分发文档,它需要npm和gulp才能轻松编译 sass,而docker4drupal默认没有。 我尝试通过sudo apt-get install npm安装在容器中,它说: 须藤:apt ...

暂无
暂无

声明:本站的技术帖子网页,遵循CC BY-SA 4.0协议,如果您需要转载,请注明本站网址或者原文地址。任何问题请咨询:yoyou2525@163.com.

 
粤ICP备18138465号  © 2020-2022 STACKOOM.COM