繁体   English   中英

Fabric Api 安装在上述版本上。 智能理念

Fabric Api is installed on the version above. IntelliJ Idea

提示:本站收集StackOverFlow近2千万问答,支持中英文搜索,鼠标放在语句上弹窗显示对应的参考中文或英文, 本站还提供   中文繁体   英文版本   中英对照 版本,有任何建议请联系yoyou2525@163.com。

我不明白如何解决它。 Build.gradle & properties 是正常的,但是 Fabric Api 安装了一个以上版本。

我知道他要求更高版本的 Minecraft。 但我需要 1,18,1

这是一个日志

[11:41:49] [main/WARN] (FabricLoader/Resolution) Mod resolution failed
[11:41:49] [main/INFO] (FabricLoader/Resolution) Immediate reason: [HARD_DEP_INCOMPATIBLE_PRESELECTED fabric 0.47.8+1.18.2 {depends minecraft @ [~1.18.2-alpha.22.5.a]}, ROOT_FORCELOAD_SINGLE fabric 0.47.8+1.18.2]
[11:41:49] [main/INFO] (FabricLoader/Resolution) Reason: [HARD_DEP fabric 0.47.8+1.18.2 {depends minecraft @ [~1.18.2-alpha.22.5.a]}]
[11:41:49] [main/INFO] (FabricLoader/Resolution) Fix: add [], remove [], replace [[fabric 0.47.8+1.18.2] -> add:fabric 1 ([(-∞,∞)])]
[11:41:49] [main/ERROR] (FabricLoader) Incompatible mod set!
 net.fabricmc.loader.impl.FormattedException: Mod resolution encountered an incompatible mod set!
A potential solution has been determined:
     - Replace mod 'Fabric API' (fabric) 0.47.8+1.18.2 with any version that is compatible with:
         - minecraft 1.18.1
Unmet dependency listing:
     - Mod 'Fabric API' (fabric) 0.47.8+1.18.2 requires any version between 1.18.2-alpha.22.5.a (inclusive) and 1.19- (exclusive) of 'Minecraft' (minecraft), but only the wrong version is present: 1.18.1!
    at net.fabricmc.loader.impl.FabricLoaderImpl.load(FabricLoaderImpl.java:190) ~[fabric-loader-0.14.8.jar:?]
    at net.fabricmc.loader.impl.launch.knot.Knot.init(Knot.java:148) ~[fabric-loader-0.14.8.jar:?]
    at net.fabricmc.loader.impl.launch.knot.Knot.launch(Knot.java:68) [fabric-loader-0.14.8.jar:?]
    at net.fabricmc.loader.impl.launch.knot.KnotClient.main(KnotClient.java:23) [fabric-loader-0.14.8.jar:?]
    at net.fabricmc.devlaunchinjector.Main.main(Main.java:86) [dev-launch-injector-0.2.1+build.8.jar:?]

Process finished with exit code 1```
1 个回复

您需要 Fabric API 的匹配版本。

您选择的版本requires any version between 1.18.2-alpha.22.5.a 因此,您不能将它用于 Minecraft 1.18.1,您需要获取旧版本的 Fabric。

Fabric 网站我可以看到您应该使用0.46.6+1.18版本的面料。 更新您的 gradle 文件,如本网站所示。

3 此Android SDK需要Android Developer Toolkit版本22.0.0或更高版本。

好吧,我真的受够了这个错误。 ..我用12个API更新了我的SDK,并收到此错误。 在更新之前一切正常。 但是在更新SDK之后,我无法解析java.lang.Object,并且由于构建路径不完整而无法构建该项目。 找不到java.lang.Object的类文件。 修复构建路径,然后尝试 ...

2014-01-08 17:44:38 1 170   android
6 Intellij IDEA版本信息

我正在使用IDEA 10.5社区版。 我在不同的版本控制系统(CVS或Mercurial)下有几个模块。 我还在编辑器中打开了多个标签。 是否可以设置IDEA,以便在编辑器选项卡中看到文件的版本信息? 是否也可以设置它,以便在“项目”窗口中查看文件的版本信息? ...

7 此Android SDK需要Android Developer Toolkit版本22.0.0或更高版本。 当前版本是21.xx

嗨,当我启动Eclipse时,我的Eclipse和SDK存在问题(我已经下载并安装了最新的Windows ADT捆绑包),我遇到了这个问题: 我尝试了以下选项:帮助->检查更新,但是没有找到新的更新,然后尝试以下操作: 但是我没有选择单击下一步完成的选项(“后”,“下一步” ...

9 使用keystore android。 定位到版本18及更高版本。 必须使用不赞成使用的方法调用?

我正在开发使用Android KeyStore API调用来加密某些字符串值的应用程序。 我的目标是API级别18和更高版本。 我的代码中有一个if else块,其目标API级别为18到23。我的问题是我要么必须在该块中使用已弃用的方法调用,如下所示(是我的if块) 在不赞成使用方法 ...

暂无
暂无

声明:本站的技术帖子网页,遵循CC BY-SA 4.0协议,如果您需要转载,请注明本站网址或者原文地址。任何问题请咨询:yoyou2525@163.com.

 
粤ICP备18138465号  © 2020-2022 STACKOOM.COM