繁体   English   中英

IONIC - 从 9.1.0 升级到 cordova-android11

[英]IONIC - Upgrading to cordova-android11 from 9.1.0

我正在将 Ionic cordova-android 升级到最新版本 (11)。但是在添加平台时我遇到了以下错误

运行 ionic 时出错 cordova platform add android@11

我已将几行添加到 config.xml 文件中。

添加标签以替换 config.xml 中的旧启动标签

将 android-targetSdkVersion 定位到 32

此外,在使用 ionic cordova build android 构建应用程序时,我收到此错误

ngModule 装饰器的构建错误

如果我在这里遗漏了什么,请告诉我。谢谢。

升级 cordova-android 时以及更新目标 SDK 时,有很多重大更改。我强烈反对一次完成所有这些更改。 我会做的是一个一个地更新它们。 并仔细阅读更新文档(也是次要更新和补丁更新的文档):

https://cordova.apache.org/announcements/2021/07/20/cordova-android-10.0.0.html https://cordova.apache.org/announcements/2120/1022/android-release/07 .0.html还有次要版本更新的文档。

我不记得这个特定的错误,但你使用的是什么 JDK。 其中一项重大更改是您必须从 8 更新到 11。可能就是这个。 但是同样,当你解决了这个问题后,你只会得到一个不同的错误。 有太多重大变化,无法一次全部完成。

暂无
暂无

声明:本站的技术帖子网页,遵循CC BY-SA 4.0协议,如果您需要转载,请注明本站网址或者原文地址。任何问题请咨询:yoyou2525@163.com.

 
粤ICP备18138465号  © 2020-2024 STACKOOM.COM