从源代码进行编译时,我永远不知道该使用哪个配置标志来针对我的环境优化编译。 假定以下硬件/操作系统:

  • 单核2 GHz Intel
  • 512MB内存
  • Debian 4

我通常只是和

./configure --prefix=/usr/local

我应该做别的吗?

===============>>#1 票数:1

我总是使用Debian软件包。 在库冲突期间,从源代码进行编译可能会破坏您的开发环境,并且此类问题很难发现。

===============>>#2 票数:0

您可能想将这几个选项检出,这在Ruby On Rails环境中可能是必需的,在这种情况下,应将它们编译。 只要确保目录与您当前的设置相对应即可。

--with-openssl-dir = / usr --with-readline-dir = / usr --with-zlib-dir = / usr

===============>>#3 票数:0

我建议混入Debian Unstable feed中的一些软件包。 尽管有名称,它们通常都很稳定。 他们也很新。

  ask by jerodsanto translate from so

未解决问题?本站智能推荐:

3回复

如何在debian squeeze上将ruby1.9.1设置为默认版本

我使用Debian Squeeze作为我的操作系统,并且正在尝试开发Ruby on Rails项目。 为此,我首先安装了一些ruby包。 我的ruby版本是:ruby1.8,ruby1.9.1 然后我卸载ruby1.8使ruby1.9.1成为我的默认ruby。 现在,如果我跑
1回复

如何在Debian中从GRUB救援模式安装内核

我正在从USB棒上安装Debian Wheezy。 在安装过程中,它给出的错误是“无法安装内核”,因此我选择以后安装它的选项。 现在,完成安装后,系统将无法启动。 它进入grub模式,并显示蓝屏并显示“ grub>”提示。 谁能告诉我该怎么办,这样我就不需要从头开始重新安装就可以正
1回复

在debian中安装没有./configure文件的程序

这可能是一个愚蠢的问题,但我不知道如何/在哪里放置Blender的文件。 从存储库中,唯一可用的版本是2.63,但是我想要2.69的Blender。 直接从blender.org下载文件为我提供了一个可运行的程序,但是如何将其放在机器上,就像通过apt-get通过存储库安装一样? 诸如
1回复

远程激活debian-installer中的网络控制台

我正在尝试远程安装服务器机架。 我的预言似乎在安装过程中挂在了物理服务器上,因此我尝试按此处所述激活debian-installer的网络控制台。 因为我的IP地址在dhcp服务器中定义为静态,所以我跳过了网络接口的静态分配,所以我的前置代码如下所示: 我的安装(在虚拟机上进行测试)
1回复

如何在安装CD中编辑现有的Debian软件包?

我一直在尝试编辑Debian安装CD,遵循debian网站https://wiki.debian.org/DebianInstaller/Modify/CD上的教程,成功提取了cd,使用genisoimage重新创建iso,尝试安装debian,没问题。 然后是问题,当我尝试编辑一个软件包
1回复

Insserv和LSBbase:修复Debian中的Aptitude吗? 无法安装任何东西,为什么?

错误报告在这里和这里 。 这里的说明建议使用insserv,但我无法安装任何东西,因此无法运行insserv。 我该如何解决这个问题?
1回复

如何通过Ansible在Debian上安装phpmyadmin?

在Debian 7.3上,我通过ansible剧本安装了nginx,mysql,php-fpm。 通常,通过以下方式安装PHPMyAdmin时 它需要数据库密码,并进行一些配置。 现在要创建一个游戏以安装和配置PHPMyAdmin怎么办? UPDATE 我写了一部
3回复

在Linux Debian上安装SciPy

我是一个Linux n00b,我想安装SciPy帮我做作业。 这个页面让我困惑不仅仅是帮助了我。 我一直在指导自己从sourceforge获得的INSTALL.txt文件,该文件说 通过Synaptic Package Manager,我下载了所有这些+ IPython。
1回复

在Debian Jessie上安装maridb

我在Debian 8 Jessie上安装了mariaDB 10,但是在安装时发生了一些错误。 使用《安装指南》 https://downloads.mariadb.org/mariadb/repositories/#mirror=host-europe时 ,mariadb 10.1发生了
1回复

如何在Debian 7.7上安装graphviz?

我是编程新手。 我刚刚安装了Debian并安装了以下软件包 我还使用以下程序从Graphviz开始: 但是我得到的是: 请让我知道如何处理这个问题? 问候