我正在尝试在Java 1.6中设置休眠模式3.2。 它与Java 1.6兼容吗? 因为HSQLDB 2.2.6需要Java 1.6! 谁能帮忙。

===============>>#1 票数:0 已采纳

Hibernate 3.2应该可以在Java 6中运行(Java至少始终向后兼容一个版本)。

或者,您可以获取为Java 5编译的HSQLDB 2.2.6 jar。

可从http://hsqldb.org/support/获得

在Maven上也可用。 请参阅此处以获取可以在配置中指定的可用罐子:

http://mirrors.ibiblio.org/pub/mirrors/maven2/org/hsqldb/hsqldb/2.2.6/

请注意,您可以使用与2.2.6更兼容的休眠方言。 Hibernate 3.2中的方言是为HSQLDB 1.8.x设计的。 它可与2.2.6一起使用,但为获得最佳结果,可以使用“集成”目录中2.2.6发行版zip中提供的传统Hibernate 3.3方言。 您可能需要稍微修改此方言才能与Hibernate 3.2一起使用。

  ask by Javavn translate from so

未解决问题?本站智能推荐:

关注微信公众号