我在zendframework中创建了一个项目:

zf create project dev.gamenomad.com

然后,我把这个:

    <VirtualHost *:80>
  ServerAdmin webmaster@dummy-host.localhost
  DocumentRoot "C:/apache/docs/dev.gamenomad.com/public"
  ServerName dev.gamenomad.com
  ServerAlias dev.gamenomad.com
ErrorLog "logs/dev.gamenomad.com-error.log"
  CustomLog "logs/dev.gamenomad.com-access.log" common
</VirtualHost>

我把它放在:C:\\ WINDOWS \\ system32 \\ drivers \\ etc中的127.0.0.1 dev.gamenomad.com

然后,重新启动。

我在输入此网址时收到此消息:

http://dev.gamenomad.com/

禁止访问!

您无权访问所请求的目录。 没有索引文档,或者目录受到了读保护。

如果您认为这是服务器错误,请与网站管理员联系。 错误403 dev.gamenomad.com 12/11/2011 8:12:29 PM Apache / 2.2.17(Win32)mod_ssl / 2.2.17 OpenSSL / 0.9.8o PHP / 5.3.4 mod_perl / 2.0.4 Perl / v5。 10.1

为什么会出现该错误?

===============>>#1 票数:1 已采纳

您收到此错误的原因是未启用目录列表,也没有找到默认文档。

将以下代码添加到VirtualHost以显示目录中的文件列表

Options +Indexes

或者创建一个名为index.html的文件(或已安装的任何其他受支持的扩展名),然后将一些内容放入文件中

您可能还希望考虑将以下内容添加到VirtualHost中,以允许访问该目录

<Directory "c:\{path_to_directory}">
    Options None
    AllowOverride None
    Order allow,deny
    Allow from all
</Directory>

根据OP的评论进行编辑

您已经具有以下VirtualHost配置。

ServerAdmin webmaster@dummy-host.localhost DocumentRoot“ C:/apache/docs/dev.gamenomad.com/public” ServerName dev.gamenomad.com ServerAlias dev.gamenomad.com ErrorLog“ logs / dev.gamenomad.com-error.log “ CustomLog“ logs / dev.gamenomad.com-access.log”常见

更改配置以添加“ Options和“ Allow设置,您将可以在localhost上运行您的网站,但可以解决您的错误。

<VirtualHost *:80>
    ServerAdmin webmaster@dummy-host.localhost
    DocumentRoot "C:/apache/docs/dev.gamenomad.com/public"
    ServerName dev.gamenomad.com
    ServerAlias dev.gamenomad.com
    ErrorLog "logs/dev.gamenomad.com-error.log"
    CustomLog "logs/dev.gamenomad.com-access.log" common
    Options +Indexes

    <Directory "c:\{path_to_directory}">
        Options None
        AllowOverride None
        Order allow,deny
        Allow from all
    </Directory>
</VirtualHost>

===============>>#2 票数:0

请参阅Apache的AllowOptions指令。

  ask by Dmitry Makovetskiyd translate from so

未解决问题?本站智能推荐: