我不知道这次发生了什么不同 - 我当地的环境运行良好。 我的heroku应用程序运行良好。 我推了一些代码,现在似乎资产管道在我的heroku应用程序中崩溃了?

/assets/all.css和/assets/application.js现在产品“未找到”错误。

什么可能导致这个或我如何能够解决它的想法?

要清楚 - 我的应用昨天工作得很好。 我没有更改有关资产管道的配置。

===============>>#1 票数:1

正如ream88所说,你需要使用雪松堆栈来使用Asset Pipeline。 您需要使用--stack cedar选项创建一个新的heroku项目并稍微修改您的gemfile

我有关于这个主题的博客文章 如果您不需要,可以跳过指南针/引导程序。

===============>>#2 票数:0 已采纳

为了将来参考,这显然是heroku当天的硬件故障,他们在第二天通过电子邮件通知了我。

  ask by Elliot translate from so

未解决问题?本站智能推荐:

1回复

如何在heroku上禁用资产管道?

heroku雪松隐含地预编译我的资产,即使我写了: 如何禁用资产功能?
2回复

有没有办法在推送到heroku时将资产管道资产资产到s3?

有没有一种简单的方法可以通过资产管道和部署到heroku / s3来实现这一目标? 我希望我的本地rails应用程序在正常情况下在本地使用image / css / js。 当你预编译时,是否有一种简单的方法让生产应用程序从s3提供它的资产(而dev资源是本地的)。 而且当你预编译
2回复

Rails 3.1资产管道 - 关闭Heroku上的图像资产指纹识别?

因为我在我的应用程序中使用的jQuery插件直接引用了图像,所以我试图关闭资产指纹识别。 所以我在我的production.rb中设置了config.assets.digest = false ,但现在我的图像引用都没有。 /assets/foo.png只返回一个空白响应。 我真的
2回复

在Heroku上部署后资产丢失

我是RoR的新手,部署后我失去了资产。 我尝试在本地预编译资产,重新启动生产服务器,删除该应用程序,然后再次重新安装它。 这些似乎都没有帮助。 它可以在开发服务器上正常工作。
6回复

将主人推到heroku的问题

我正在关注在线铁路教程 一切都很好但是在尝试将主目录推送到heroku时。 当它出现时: 现在的问题是:我使用的是ruby 1.9.2,甚至没有安装1.8.7。 当我列出我的本地宝石时,bundle有这两个版本:bundler(1.0.2,1.0.1)(我不知道为什么)所以似乎
1回复

Heroku没有显示我的资产

我已经在本地计算机上预编译了我的资产,但是当我将其推送到heroku时,我的所有资产不再可用,它们似乎没有进行编译。 我最近不得不重新安装rails / ruby​​ / rvm,这是错误开始发生的时间。 让我知道是否能给您更多信息。
2回复

Heroku不能预编译我的资产吗?

我有一个Rails 3.2应用程序,它给了我一个“很抱歉,但是出了点问题。” 我部署到heroku时出现提示信息。 检查日志有 以及其他看起来非常相似的东西。 我已经为此进行了很多工作,并且看到了其他一些类似的问题,所以我将避免一些您认为可能存在的潜在问题: 在推送到he
3回复

Heroku预编译资产失败

更新后,我的应用程序突然无法运行。 不确定出了什么问题。 基本上,当我推送到heroku时,我得到这些错误: 再高一点: 当我实际加载网站时(“我们很抱歉,但出现问题”),并查看heroku日志,我得到了这个: (Kreon是一个额外的字体,我添加了一段时间后工作正常
3回复

Heroku编译资产超时

从今天开始,我在资产编译方面遇到超时异常: 更新: 有任何想法吗? 谢谢
1回复

尽管在本地编译资产,但Heroku资产预编译错误

我目前是第一次将应用程序部署到Heroku,并遇到预编译错误。 当我执行命令git push heroku master ,我得到: 经过一番搜索,我遇到了Heroku自己的关于预编译错误的疑难解答指南 ,以及有关预编译错误和Rails 3.2的帖子 ,并按照它们的指示进行了以下操作: