我已按照此说明(适用于Macosx): http ://nokogiri.org/tutorials/installing_nokogiri.html

的Gemfile

gem 'nokogiri'

控制器代码:

require 'rubygems'
require 'nokogiri'
require 'open-uri'

我使用Rails 3.1.3

LoadError in ScriptsController#tv2db

no such file to load -- nokogiri

如果我使用“irb”,那没关系

>> require 'nokogiri'
=> true

===============>>#1 票数:7 已采纳

别忘了重启服务器。

  ask by sparkle translate from so

未解决问题?本站智能推荐: