我从这里安装了m2e 1.0最新版本

http://download.eclipse.org/technology/m2e/releases

我不得不删除 eclipse的旧maven集成 ,以及eclipse WTPmaven集成

安装这个最新版本,并重新启动eclipse后,我发现maven菜单从右键单击项目消失,所以我虽然我需要m2e附加功能,但我找不到兼容版本,请指教。

===============>>#1 票数:9 已采纳

新的Maven插件使用不同的项目元数据(由于迁移到Eclipse基础和新的包名称)。 因此它无法识别较旧的Maven项目。 您必须再次为每个项目启用Maven以创建新元数据。 为此,右键单击项目,选择“配置”,然后选择“转换为Maven项目”。 现在应该出现“Maven”子菜单。

===============>>#2 票数:0

您运行的是哪个版本的Eclipse? 在下载页面中,他们说m2e是针对Eclipse 3.6(Helios)和3.7(Indigo)进行测试的。

  ask by Mahmoud Saleh translate from so

未解决问题?本站智能推荐:

2回复

Maven for Eclipse(M2E)安装错误

错误详情: 无法完成安装,因为找不到一个或多个必需的项目。 正在安装的软件:m2e - Eclipse的Maven Integration 1.4.0.20130601-0317(org.eclipse.m2e.feature.feature.group 1.4.0.20130601
6回复

使用maven war插件的Web资源过滤在使用m2e的Eclipse中不起作用

我正在尝试使用Maven过滤过滤Spring配置文件。 我的POM配置如下: 和 它直接调用Maven时效果很好。 不幸的是,当使用Eclipse WTP和m2e在Tomcat 6中热部署webapp时,它总是选择未经过滤的applicationContext.xml版本
1回复

我如何知道我安装了哪些Eclipse M2E连接器?

据我所知,Eclipse中的新M2E具有可插拔连接器,可帮助根据项目导入时在POM中看到的内容来配置Eclipse项目。 我也相信(大多数情况下)这些连接器在需要时(按需)自动安装。 我一直在使用它们取得了一些成功。 最近我手动安装了M2E-WTP连接器,因为我想尝试一下。 我通
3回复

未在Eclipse Luna中安装m2e扩展

当我安装m2e扩展程序时,它给我以下错误: 我正在使用此URL下载: http : //download.eclipse.org/technology/m2e/releases
2回复

无法安装M2E生命周期映射

将Eclipse Kepler版本更新为20130919-0819之后,我需要重新安装m2e生命周期映射。 但是,当我尝试打开用于安装生命周期映射的对话框时(通过“首选项”或POM查看器消息中的链接),将显示以下错误消息: Eclipse错误日志显示以下异常: 我已经尝试使用全
4回复

Eclipse 3.7 / Indigo m2e WTP集成依赖问题

我刚刚从Helios切换到Eclipse Indigo,当尝试使用WTP在Tomcat 6上运行支持Maven的Web项目时,我遇到了一些麻烦。 我遇到了Tomcat没有看到Maven依赖项的经典问题。 在Helios中,解决方法是通过以下方式将Maven依赖项添加到Deployment
2回复

M2E WTP复制提供的Jar

我有一个自定义的类加载器jar <scope>provided</scope> ,它必须在运行我的Web应用程序之前在tomcat / lib中,否则它将无法启动。 我正在使用WTP。 有什么方法可以配置M2E / WTP在部署过程中自动将此自定义jar复制到tomc
1回复

M2e中的EAR模块

我正在将现有项目结构转换为Maven,在Maven中已部署的EAR中包含EJB和JAR。 我的问题是制作耳朵。 使用Maven EAR插件似乎很明显,它可以使用现有的application.xml或基于configuration.modules生成一个。 我觉得如果我不使用modules配
3回复

WTP - m2e没有部署传递依赖

我有一个以这种方式构建的Web应用程序: A.jar - > B.war - > C.war 我正在使用Eclipse Juno,而WTP版本是1.1 。 A.jar是一个工作空间实用程序项目,由B.war包含。 B.war是一个战争项目,由C.war作为叠加层包含在
2回复

jaxb2-maven-plugin一个m2e连接器

从回购中清除结帐/克隆后,我在执行jaxb2-maven-plugin xjc目标时在eclipse中收到此错误。 在“更新Maven配置”之后,仍不会生成代码。 在我的neon3 eclipse(4.6.3)中,我已经安装了m2e插件(1.7.1)以及“ jaxb2的m2e连接器”(4.0