繁体   English   中英

除了适用于Python的matplotlib之外,还有其他图形模块吗?

Is there any other graphic module besides matplotlib for Python?

提示:本站收集StackOverFlow近2千万问答,支持中英文搜索,鼠标放在语句上弹窗显示对应的参考中文或英文, 本站还提供   中文繁体   英文版本   中英对照 版本,有任何建议请联系yoyou2525@163.com。

我觉得matplotlib运行缓慢,并且想尝试其他轻巧,敏捷的图形包。我主要将绘图用于业务演示,而不是用于科学目的。 有什么建议吗?

2 个回复

您可以尝试:

http://code.google.com/p/visvis/
http://code.google.com/p/cagraph/

plplot的python绑定 ...

如果您觉得不一定需要用Python实现代码,则可以尝试基于Latex的绘图:

http://www.texample.net/tikz/examples/
http://pgfplots.sourceforge.net/gallery.html

也有查科。 无论如何它都不是轻量级的,但是在我有限的测试中,它比matplotlib快了一点。

http://code.enthought.com/projects/chaco/

我最终还是住了matplotlib,因为它更受欢迎,因此它在社区中提供了更好的支持,以帮助您解决问题等。

2 适用于Python 3的MySQL模块

据我了解,MySQLdb不支持Python3。我听说过PyMySQL可以替代此模块。 但是它在生产环境中如何工作? 两者之间的速度差异是否很大? 我之所以问是因为我将管理一个非常活跃的Web应用程序,该应用程序需要经常在数据库中创建条目。 ...

4 更改不适用于python模块

我对python比较陌生。 我已经开始使用并完成一个开发不足的python库。 但是,我在模块中所做的更改不适用。 也就是说,我调试了代码,并且list命令向我显示了模块的初始版本。 这些是我尝试解决问题的方法: 1-重启终端 2-使用reload命令重新加载已更改的模块 ...

5 适用于Python的音乐模块

我正在努力寻找适合我所有需求的模块。 我需要一个与Python 3.XX兼容的模块,该模块可以播放,暂停和排队MP3曲目。 Pyglet表现不错,但多年未更新,并且Queue函数不适用于Python3。对我应该使用哪个模块有何建议? ...

6 适用于Python的FANN2-Matplotlib浮点格式问题

我今天的问题是关于同时使用matplotlib或pyqtgraph Python 2的fann2软件包的奇怪行为。 可以说,我需要实时绘制我的FANN网络MSE。 然后,我将使用具有交互性的matplotlib和一些while True循环或Thread更新我的绘图。 但是为简单起见, ...

7 matplotlib中的RC变量不适用于Web应用程序中的图形,轴

我正在尝试使用生成图形的Web应用程序中设置matplotlib的线宽 当在交互模式下使用matplotlib时,此方法可以很好地工作,但是在我的Web应用程序中它没有任何作用,而获得正确行宽的唯一方法是在各个调用中提供参数,即: 是否有一些技巧可以使matplotlib.rc调 ...

9 Matplotlib-图形图例不适用于具有多个轴的多个子图

上面的代码将生成如下图: 我在stackoverflow上进行搜索,并获得以下代码来执行图例: 但这没有效果。 这就是我想要的。 我截取了我的情节的屏幕截图,并从另一个情节中生成了图例,然后对其进行了照相购物: 我怎样才能做到这一点? ...

10 请求模块不适用于 Python3,但适用于 Python

当我输入时,它显示我已经安装了请求模块: pip3 install requests 回复: 所以当我用代码创建一个名为 http.py 的文件时: 我收到一条错误消息: 但是当我用 python2 运行这段代码时: 我没有错误并打印出来: 200 我曾尝试使用 pip3 卸载和 ...

暂无
暂无

声明:本站的技术帖子网页,遵循CC BY-SA 4.0协议,如果您需要转载,请注明本站网址或者原文地址。任何问题请咨询:yoyou2525@163.com.

 
粤ICP备18138465号  © 2020-2021 STACKOOM.COM