繁体   English   中英

从Richfaces 3.3.2最终迁移到Richfaces 4.0.0

Migrating from richfaces 3.3.2 to richfaces 4.0.0 final

提示:本站收集StackOverFlow近2千万问答,支持中英文搜索,鼠标放在语句上弹窗显示对应的参考中文或英文, 本站还提供   中文繁体   英文版本   中英对照 版本,有任何建议请联系yoyou2525@163.com。

我试图将Web应用程序从richfaces 3.3.2迁移到4.0.0,所以我更改了web.xml文件中的必要内容(servlet映射“ .xhtml”并删除了Ajax4jsf过滤器)。 我也将richfaces 3 jars更改为第4版,但是现在我遇到了一些错误,不知道如何解决它们:

The import org.ajax4jsf cannot be resolved
The import org.ajax4jsf cannot be resolved
The import org.ajax4jsf cannot be resolved
The import org.richfaces cannot be resolved
The import org.richfaces cannot be resolved
The import org.richfaces cannot be resolved
Incompatible conditional operand types UIComponent and UICalendar
UICalendar cannot be resolved to a type
HtmlToolTip cannot be resolved to a type
HtmlToolTip cannot be resolved to a type
HtmlToolTip cannot be resolved to a type
Incompatible conditional operand types UIViewRoot and AjaxViewRoot
AjaxViewRoot cannot be resolved to a type
AjaxViewRoot cannot be resolved to a type
org.ajax4jsf cannot be resolved to a type
EventsQueue cannot be resolved to a type
HtmlAjaxSupport cannot be resolved to a type
HtmlToolTip cannot be resolved to a type
Incompatible conditional operand types UIComponent and HtmlCalendar
HtmlCalendar cannot be resolved to a type
HtmlToolTip cannot be resolved to a type
HtmlToolTip cannot be resolved to a type
HtmlToolTip cannot be resolved to a type
HtmlToolTip cannot be resolved to a type
HtmlToolTip cannot be resolved to a type

有人可以帮我吗?

2 个回复

缺少richfaces-core-impl库

Javadoc AjaxViewRoot v4

删除web.xml文件中的RichFaces 3.3 Ajax筛选器

         <filter>
                <display-name>RichFaces Filter</display-name>
                <filter-name>richfaces</filter-name>
                <filter-class>org.ajax4jsf.Filter</filter-class>
          </filter>

            <filter-mapping>
                <filter-name>richfaces</filter-name>
                <servlet-name>Spring MVC Dispatcher Servlet</servlet-name>
                <dispatcher>REQUEST</dispatcher>
                <dispatcher>FORWARD</dispatcher>
                <dispatcher>INCLUDE</dispatcher>
            </filter-mapping>

RichFaces 4.0.0最终打开的webmvc-config.xml文件将其添加

       <bean id="flowController" class="org.springframework.webflow.mvc.servlet.FlowController">
            <property name="flowExecutor" ref="flowExecutor" />
            <property name="ajaxHandler">
                <bean class="org.springframework.faces.webflow.JsfAjaxHandler" />
            </property>
        </bean>
3 从Angular 2迁移到4.0.0的错误

(已编辑的问题)升级软件包和依赖项之后, 使用upgrade命令将角度软件包升级到4.0.0并没有帮助。 我正在按常规顺序npm run build npm run clean , npm install和npm run build 。 我应该更改打字的版本吗? ...

2017-03-29 21:03:39 3 193   angular
6 迁移到Richfaces 4时出现问题

我严格遵守了本文档中提到的所有要点,但是当我运行我的应用程序时,它在Tomcat 6.0.29上运行时报告以下问题 (我在类路径中包含Mozzara 2.0.4和jstl1.1)。 该应用程序可在Richfaces 3.3.3上完美运行 是JSf 2应用程序 严重:由 ...

7 RichFaces 3 到 RichFaces 4 的迁移

我目前正在处理一个项目,我想将其从 3.3.3.Final 版本迁移到 RichFaces 4。 我在想... 在迁移之前,我应该考虑、了解或考虑什么重要的事情吗? (可能是一个愚蠢的问题,但是...)你可以“混合”richfaces 3 和richfaces 4 吗? 我想要切换的 ...

暂无
暂无

声明:本站的技术帖子网页,遵循CC BY-SA 4.0协议,如果您需要转载,请注明本站网址或者原文地址。任何问题请咨询:yoyou2525@163.com.

 
粤ICP备18138465号  © 2020-2021 STACKOOM.COM