标签[cocoapods]

CocoaPods是Cocoa项目的依赖项管理器。

0
0回复
06

我无法将Firebase Crashlytics CocoaPods添加到我的Xcode项目中

我正在按照https: firebase.google.com docs crashlytics get started ios hl es 中的说明进行操作 这一点: 我收到此错误: 我检查了与Gi
-1
0回复
12

Firebase Pod更新未更新

Xcode版本: . . 播客版本: . . 以下是我的pod文件: 所以我运行命令 连连看都没有更新 以下是我的终端的详细信息: 如您所见,与Firebase相关的所有内容均未更新
0
0回复
07

未定义的符号:没有cocoapods的库的链接程序命令失败

我正在使用Unity来构建iOS应用。 我曾经习惯于图书馆,比如说A和B。B要求我使用pod install repo update 。 我这样做并运行了xcworkspace文件。 在尝试构建应用程
0
0回复
15

为什么可可豆不安装Alamofire 5?

我为我的应用程序的iOS和macOS版本有两个单独的项目。 我想同时使用Cocoapods安装相同版本的Alamofire。 它们都在Swift 上,其部署目标是iOS . 和macOS . 。 根据
0
0回复
14

Cocoapods Spec Lint非模块化接头

我试图将Rocksdb的Swift包装器推到Cocoapods。 到目前为止,我已经成功地推动了绑定,绑定是一个单独的pod librocksdb 。 但是依赖librocksdb的pod,例如我的包
0
0回复
21

使用cameramanager Cocoapods时,如何在全屏cameraView上显示按钮?

当前,我正在使用以下代码来显示cameraView,它被约束为只能获取整个视图。 然后,我使用情节提要板在cameraView上添加了一个按钮。 但是,在加载视图之前,该按钮会在屏幕上显示一秒钟,然后
0
0回复
05

在Windows 10上运行Cocoapods时,您在哪里获得unzip.exe?

我花了几个小时在周围搜索,找不到适用于Windows 的unzip.exe。有人共享链接吗 我的另一个想法是,CocoaPods可能实际上无法在Windows上运行,也许只能与Linux的Window
0
0回复
06

Cocoapods Swift框架自定义配置

我正在创建一个具有自定义配置和架构的全新项目,但是当使用自己的自定义swift框架时,出现 找不到框架 的信息 。 如果我将UI框架中的配置从 Debug更改为 Debug Development则可
0
1回复
37

删除了Realm,但仍然出现此错误:模块导入失败:无效令牌(rlm_lldb.py,第37行)文件“ temp.py”,第1行

两年前,我在一个项目中尝试将Realm与Cocoapods结合使用。 Realm无法解决问题,因此我将其删除。 Cocoapods无法解决问题,因此我最终也将其删除,并改用Carthage。 随着Xc
2
0回复
17

Travis CI构建[Cocoapod Swift]失败,没有“此类模块…”错误

我有一个用Swift编写的存储库 ,这是一个标准的cocoapod工作区 标准格式,其中包含使用Quick and Nimble测试创建的示例应用程序,没有UI测试 ,该存储库在本地计算机 Xcode
-1
0回复
12

忽略R.Swift中的Segue资源

如何忽略R.swift可可豆荚文件 R.genic 中的segue生成器
0
0回复
24

未知的iOS错误:“错误:模块导入失败:无效的路径名”

我正在使用Xcode . . 和Mac OS Catalina . . 。 运行iOS应用时,我在模拟器和iOS . . 的每台设备上都收到此错误: 我已经搜索了Google和StackOverflo
1
0回复
14

无法从Cocoapods渲染SwiftUI预览

我在自己提供的公共库中有一个SwiftUI结构。 public struct NTextField: View public var body: some View Text Hello, World
0
1回复
26

无法构建Objective-C模块/无此类模块

几天前,我的iOS应用程序运行良好,然后突然由于Cocoapods似乎无穷无尽的问题而无法构建它。 首先我得到了这个错误: 然后我注意到,如果我注释掉了该违规行,那么我只会遇到另一个 pod模块的问题
0
1回复
26

快速使用新Podfile时如何忽略警告?

您好,我实现了与cocoapod不同的库并安装Podfile 但我想忽略警告
0
1回复
11

错误ITMS-90171:无效的捆绑结构-二进制文件[CocoaPods文件]

上载到App Store时遇到此错误: 我搜索了所有类似的帖子,并尝试了所有这些建议: 始终嵌入Swift标准库 true,false, 继承 构建阶段 gt 复制捆绑资源 gt 确保其没有框架 确保
0
1回复
11

如何在特定的cocoapods窗格中使用`use_frameworks!`?

我知道如果您正在使用Cocoapods,则应将所有Pod用作框架或静态库。 无法使用框架指定某些容器,而使用静态库指定其他容器。 但是我只想尝试询问或讨论这个问题。 也许会有一些棘手的解决方案。 我正
1
0回复
41

当我的框架包含.framework文件时,为什么会出错?

我的项目使用cocoapods来管理框架。 podfile包含命令行 我的框架core依赖于另一个框架UMCCommon 。 因此core框架的podspec文件具有命令行 但是UMCCommon有一
1
1回复
20

如何从商店中的iOS App中删除Firebase分析

我目前在应用商店中有一个应用。 它使用Firebase分析框架。 我是通过cocoapods安装的。 例如。 pod FirebaseAnalytics pod FirebaseAnalytics 在
0
1回复
20

LoadError-找不到类Digest :: SHA1的库—摘要/ sha1

在运行pod install时,在安装yoga时会遇到问题。 好像是我的红宝石环境有问题 命令 堆 外挂程式 播客文件 Uncomment the next line to define a glob

1 2 3 4 5 6 7 8 9 10 下一页