cost 16 ms
Termux 没有安装 gem nokogiri

构建原生扩展。 这可能需要一段时间... 错误:安装 nokogiri 时出错:错误:无法构建 gem 原生扩展。 当前目录:/data/data/com.termux/files/usr/lib/ruby/gems/3.1.0/gems/nokogiri-1.13.8/ext/nokogiri ...

2022-09-26 18:20:30 0 5
导出带有导轨的 excel 中的图表

我在我的应用程序中使用 axlsx gem 将数据导出到 excel 表。 另一方面,我使用 [quickchart] api 在前端显示图形。 无论如何使用 quickchart api in.xlsx 模板或任何其他允许我在.xlsx 模板中绘制图形的 gem,以便我可以使用图形导出数据。 很简 ...

2022-09-26 15:15:51 0 9
Ruby Mongo 库 'db.collections' 未返回任何值

我正在尝试使用以下 Mongo文档连接到 mongodb 数据库。 但是通过设置我的连接后client = Mongo::Client.new('mongodb://127.0.0.1:27017/test') 并随后创建一个数据库实例: 我仍然无法通过db.collection_names查看此数 ...

2022-09-23 05:17:05 0 9
Ruby gems 安装程序一直说我在不兼容的架构上

当它提示我这条消息时,我试图通过 ruby gems 安装ocra : 按照指示,我运行命令gem pristine strscan --version 3.0.4 ,并尝试安装另一个 gem。 不幸的是,当我尝试安装 rails 时,使用gem install rails 我突然想到的是它说“不兼 ...

2022-09-22 08:45:12 1 13
权限被拒绝@ rb_sysopen /db/sphinx/production/ts-listing_delta.tmp

大家好,我在狮身人面像索引方面面临的问题。 虽然 sphinx 搜索工作正常,但是当我发布列表时,索引不起作用。 我在这里使用延迟作业进行索引是参考索引/listing_index.rb ThinkingSphinx::Index.define:listing, :with =>:acti ...

2022-09-22 06:51:20 0 36
当条件为假时删除数据网格列

我使用 gem datagrid 在我的视图中显示列,但在这种情况下,我想在条件为 false 时完全删除列。 catalog_organization_id 是我的装饰器中的一个方法: ...

2022-09-21 21:41:24 0 9
尝试使用 bundle 安装 Byebug 时出错

gemfile 需要安装 byebug 5.0.0,我运行了 bundle 来完成所有设置。 但是,byebug 安装失败 错误信息: 获取 byebug 5.0.0 安装带有原生扩展的 byebug 5.0.0 Gem::Ext::BuildError: 错误: 无法构建 gem 原生扩展。 ...

2022-09-21 18:50:10 1 12
安装 mysql@5.7 后无法启动 rails 服务器

我最近卸载了 mysql@5.6 并安装了 mysql@5.7。 但是现在当我启动 rails 服务器时,出现以下错误。 它仍在搜索 mysql@5.6 这就是它失败的原因。 我已经启动了.zshrc服务器,甚至在我的 .zshrc 文件中添加了以下行 如果有人知道如何解决这个问题,请告诉我。 我有 ...

2022-09-21 11:12:03 1 15
Ubuntu / 路边无法安装 - 缺少什么?

我的服务器上安装了 debian wheezy 7,我正在尝试安装curb gem。 我已经安装libcurl4-gnutls-dev libcurl3 libcurl3-gnutls libcurl4-openssl-dev curl 安装: 没有任何运气 - 我在安装 gem 时遇到编译错误 ...

2022-09-21 04:51:14 0 11
将我的 rails 应用程序升级到 mysql 5.7

我有一个 Rails 应用程序,目前在 mysql 5.6 上运行,我被赋予了将 mysql 升级到 5.7 的任务。 但我是新来的,不知道如何实现这一点,而且我找不到任何相同的在线指南。 有人可以帮我详细说明如何将我的应用程序的 mysql 版本升级到 5.7,或者甚至指向解释该过程的详细文章/ ...

2022-09-20 21:14:20 0 6
如何在 Debian 11.4 上正确配置 ruby gems?

这是一个后续行动 如何运行 Ruby Gem? 在没有太多关于 ruby 的知识的情况下,我跟着 https://linuxconfig.org/getting-started-with-jekyll-on-debian-9-stretch-linux 安装 Jekyll。 我做了 但后来 jek ...

2022-09-20 09:49:24 1 15
带捆绑器的多级 docker 构建

我不确定有多少 ruby 人在这里。 我正在创建一个多阶段构建来缓存宝石。 我正在构建一个生产映像,但是当容器运行时,捆绑器输出错误如下。 问题是捆绑器正在尝试加载不在最终图像中的与开发和测试相关的 gem。 有人能告诉我如何正确使用多级 docker 构建吗? ...

2022-09-18 18:23:24 0 6
Zeitwerk 不在 Rails 7 中自动加载模型

我最近将我的应用程序的 Rails 版本从 6.1 升级到了 7,我遇到了 zeitwerk 的一个问题。 我还在我的 rails 6.1 中使用了 zeitwerk,它工作正常,但是当我将它升级到 rails 7 时突然出现了问题。 由于 zeitwerk 自动加载根目录,所以它也必须自动加载模型 ...

2022-09-17 10:57:32 1 37
通过 class 或 ID 访问元素时出现问题

我必须访问一个 div 集合并推断一些通过它循环的数据。 它正确抓取了集合(“puts names”output 确实是一个 div 集合),但它不会开始循环(“puts names.length”为 0)。 我唯一能想到的是该网站是使用 angular 构建的,并且每个元素都有一个 ng 类。 这 ...

2022-09-16 15:12:22 0 24
在 Rails 中重用 scope 的最佳方法是什么?

我对重用或编写新的 scope 感到困惑。 例如, 我的一种方法将返回未来订阅或当前订阅或 sidekiq 创建的订阅。 因为范围看起来像: 所以这些以不同的方法用于不同的目的,所以对我来说,我尝试的是检查一个特定的帐户记录是否会属于三个订阅中的哪一个。 所以我尝试过: 所以我的疑问是,这样使用是 ...

2022-09-16 09:07:35 0 28

 
粤ICP备18138465号  © 2020-2022 STACKOOM.COM