cost 14 ms
将可执行文件添加到 /usr/local/bin:找不到命令 (macOS)

我用 ruby​​ 做了一个简单的程序。 该文件顶部有shebang,它是可执行的。 当我运行它( ./parser.rb )时,它可以工作。 然后我使用ln -s parser.rb refs创建了一个符号链接。 然后我将此符号链接移至/usr/local/bin 。 我重新启动终端并运行re ...

2022-01-25 13:46:03 1 13
是否可以在 C 中打印 rgb 颜色

我想将块字符(█)打印为任何 rgb 颜色(#000000-#ffffff)。 我知道 ANSI 颜色和ANSI 8 位,但是颜色仅限于我的使用。 如何在终端上最好地实现完整的 RBG 颜色范围? 这只会用于类 UNIX/UNIX 操作系统,不会使用 windows。 ...

2022-01-25 08:11:37 1 63
"linux如何添加缺少的文件扩展名或移动没有扩展名的文件"

我有超过 7k 个文件,其中一些是 HTML,一些是 PDF,如下所示: 我现在想使用终端将所有 PDF 移动到新目录。 不幸的是,当我这样做时 我得到“没有这样的文件或目录”,因为所有文件都没有任何文件扩展名(没有 .pdf 或 .HTML)但是当我对随机文件执行以下操作时: 它确实 ...

2022-01-25 02:10:54 1 11
编码时没有 node.js 或 yarn 命令起作用

我对编码还很陌生,所以请尝试为我简化一切。 我正在尝试遵循我在终端中编码的教程(在 MacBook Air 上使用 Visual Studio)。 每次我尝试运行任何这些命令或类似的命令 yarn install npm istall node index.js 我收到一条看起来像这样的错误消 ...

2022-01-25 01:24:18 0 4
配置 jre 包时卡在 2%

每个人……这里都是新手,也是编程新手。 我正在尝试用我的 ubuntu 终端安装 jre,但我一直卡在 2% 上。 它也发生在火车上(花了大约 2 个半小时,它仍然卡住),而我试图安装其他东西......我今天刚刚安装了 ubuntu,所以也许是我在安装它时做错了什么? :-0 ...

2022-01-24 18:17:51 0 4
通过终端命令编辑 Xcode 项目

我可以在 Xcode 中打开我的一个 Xcode 项目并添加Application supports iTunes file sharing=Yes以使用 Xcode 和直接通过 Xcode,现在我正在徘徊,如果这个工作代码也完全通过终端完成? 我的目标是在终端中键入一个命令,该命令仅使用终端对 ...

2022-01-24 13:05:05 1 25
每个命令都以'zsh:找不到命令:amplify_env'结尾

我在这里遇到了一些问题。 每次我在终端中输入命令时,都会以“zsh:找不到命令:amplify_env”结尾。 不管命令是什么。 我可以在我的终端中输入类似“test”的内容,它最终会得到完全相同的消息。 每次我在终端中执行某些操作时,我的终端似乎都在尝试执行 amplify_env 命令。 有 ...

2022-01-24 11:59:49 0 5
在linux中覆盖一行和一列的值

我从我的 linux 的脚本(比如child.sh )发送邮件。 现在我想从另一个脚本覆盖行和列的值 这是邮件的代码: 邮件的输出是: 现在我想将第一行的状态覆盖为 PASSED。 (即,想要将 Bill Run 的状态覆盖为 PASSED)从另一个脚本(例如parent.sh )。 因此 ...

2022-01-24 11:14:38 0 22
GO - 循环读取标准输出

我是GO新手,我正在尝试编写一个小实用程序,我想在其中循环执行命令并读取它们的输出。 该代码有效,但只有第一次迭代产生输出。 我猜想在第一次迭代中分配标准输出会以某种方式阻止标准输出的后续使用。 有人可以解释我如何解决这个问题吗? (我简化了 IP 地址来自的代码。我从文件中读取它们,但这与问题无 ...

2022-01-24 08:40:58 1 35
无法在 Solaris 11.4 上安装 GCC

我在 VirtualBox 中安装了Solaris 11.4 x86 。 我需要安装 GCC 编译器,以便我可以在 Solaris 中运行 c 代码。 但是每次我尝试安装软件包时都会发生此错误: 出版商信息: 我使用了以下命令: 还尝试了 -nv 选项 查看以下命令的输出: 输 ...

2022-01-24 08:13:16 0 24
React - MacOS (M1) - 安装 react-route-dom 错误

使用 VScode 时,尝试通过终端安装 react-route-dom(在 VSCode 中) 我不断收到此消息,而不是通过终端下载: 我不明白它有什么问题... s/o 可以提供帮助吗? ...

2022-01-23 17:47:13 1 9

 
粤ICP备18138465号  © 2020-2022 STACKOOM.COM